[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

separate boot partition and lilo

As i asked to the debian forum i'm having trouble installing debian 
etch with a separate boot partition and LILO on the MBR. Here is the 
post (you can find it here: http://forums.debian.net/viewtopic.php?

Hi! As everyone here i'm enjoing debian etch!
Only one problem and a question for you:
have you ever tried to install 
etch form scratch using the netinstall cd and using a small (< 100MB) 
/boot partition and using LILO as the boot manager on the MBR???
i've tried and it doesn't work. Well it works only if you try to 
install LILO then after the first failure switch to another console 
(ALT+F2) then type:

umount /target/boot

switch to the console 
with the installation process (ALT+F1 or ALT+F5 - GUI or not, doesn't 
matter) try to install LILO againg (it will move from the previous 50% 
to 75%) then switch to the other console (ALT+F2) and type:

/dev/whatsoever /target/boot

Switching again to the installation 
console and installing LILO again it will work fine and you are safe to 
reboot the new system.
I've tried using LILO on the first partition 
instead on the MBR but the problem is just the same.
What do you think? 
(i believe sarge installation has the same problem and... please don't 
ask me to use GRUB... that's too easy... :-) 


Reply to: