[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#418043: marked as done (acpi=off versus noapic bootparam)

Your message dated Mon, 16 Apr 2007 15:32:03 +0200
with message-id <200704161532.04362.elendil@planet.nl>
and subject line Bug#418043: acpi=off versus noapic bootparam
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Boot method: CD (using image created on March 18, 2007)
Image version: http://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/debian-testing-amd64-CD-1.iso
Date: March 23, 2007

Machine: self built from parts
Processor: amd64 X2 3800+ EE (Energy Efficient)
Memory: 2 Gb
sata1 disk (this is the first time I'm trying a system w/o separate /usr, /var, /tmp, etc.): 
/dev/sda1 ~ 12 Gb mounted on /windows
/dev/sda2 ~ 200 Gb mounted on /
/dev/sda5 ~ 12 Gb mounted on /home
/dev/sda6 ~ 12 Gb used as luks encrypted home dir mounted at login on /home/<my username>
/dev/sda7 ~ 12 Gb used as luks encrypted home dir mounted at login on /home/<my wife's username>
/dev/sda8 ~ 4 Gb encrypted swap (/dev/mapper/cswap)

1Gb tmpfs mounted on /tmp

hdb: (hda is dvd writer)
harddrive from old system with separate /, /home, /usr, /var, /var/tmp, etc. for data migration

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [E]
Detect network card:    [E]
Configure network:      [O]
Detect CD:              [E]
Load installer modules: [E]
Detect hard drives:     [O]
Partition hard drives:  [E]
Install base system:    [O]
Clock/timezone setup:   [E]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [E]
Overall install:        [E]


0. The zeroth problem was booting. Somewhere in the help where you find it right away it says
 to use noacpi if the system hangs. I tried that and it didn't work. In another spot more buried 
(I think in the special parameter section) it says use acpi=off. Well, only the acpi=off worked.

1. The first problem to crop up was with the language and timezone. I live in Germany, but am a native 
english speaker and wish to install in English. As soon as you've selected the English language, you 
can only choose timezones from the USA and it's territories. Luckily I was still *allowed* to choose 
a german keyboard! Please try thinking less for the user and allow hir to choose whichever timezone s/he
desires...I'm sure most people know which timezone they live in!

2. The second problem wasn't too much of a problem, just irritating: when detecting disks, the cd, and 
the network card, it *kept* asking me whether I wanted to install the floppy module. I would deselect it and
and continue, and in the next step it would again ask me about the floppy module. Other than that, the 
detection of cd and network card worked ok.

3. The third problem was with partitioning the harddrive.  You can tell it that you want to use a partition
as an encrypted partition, but afterwards it doesn't do anything with it and you can't tell it where you want
it mounted. I don't see what this option really does, since you have to luksFormat it, etc. by hand afterwards
anyway. It would be nice if the installer would support encrypted partitions where you could select options and
a mount point and have the installer set everything up. Especially encrypted swap is easy, it just needs an entry
in /etc/crypttab and an appropriate entry in /etc/fstab, so "encrypted swap" should be an option too!

4. The fourth and worst problem came when I tried to reboot my "new system"...didn't work at all, 
no grub screen, nothin. Had no idea why.
Tried using the install cd as rescue cd, but it wasn't much of a rescue, it just wanted to re-install. 
I re-installed twice and fiddled with the bios. Luckily, at some point I accidentally booted with my sata1 
hd disconnected and it started grub (!) but couldn't find a bootable image. Then I understood: grub had been installing itself 
to /dev/hdb, even though I hadn't installed any of the system there (hdb was my old hd from my old system 
which I had attached to transfer data from). There was never any question in the install about where grub 
should install itself other than "to the master boot record" but didn't mention which drive, and it didn't 
occur to me that it would install itself preferentially to hdb instead of to sata1 when I wasn't installing the
system there and had configured no mount points from hdb! Big Bummer and big waste of time! The other errors
were no big deal, but this really caused me some grief!


"Feel free" - 10 GB Mailbox, 100 FreeSMS/Monat ...
Jetzt GMX TopMail testen: http://www.gmx.net/de/go/topmail

--- End Message ---
--- Begin Message ---
On Monday 16 April 2007 15:02, josh wrote:
> The "special boot param" screen reports this correctly. Confusingly,
> however, the other help screens use "acpi=off" as a default bootparam
> example. This is what confused me. Here's a summary:

How many more time do I need to close this report?
My initial reply to your report was perfectly accurate: THERE ARE NO 

The documentation of the boot parameters DOES NOT NEED ANY IMPROVEMENT, 
despite what you may think.

> Since you retitled the general installation report to the specific
> bootparam issue, I'm going to open a new bug for the grub+sata issue.

Please DO NOT. This issue is well known and we already have several bug 
reports open that document it. As I said in my initial reply to you, we 
already do plan to improve this. THERE IS NO NEED FOR ADDITIONAL BUG 

No, please respect the judgement of the maintainers of the installer and 
leave this report closed. The fact that you submitted it _was_ 
appreciated, but you are now rapidly becoming a major pain in the ass.


--- End Message ---

Reply to: