[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#414203: marked as done (Installation problems: Wrong partition type for physical raid partitions)

Your message dated Sat, 10 Mar 2007 17:02:05 +0000
with message-id <E1HQ4xJ-0007L0-7d@ries.debian.org>
and subject line Bug#414203: fixed in partman-md 34
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports
Version: etch daily netinst 20070308 amd64

Machine: Dual Xeon on Intel S5000P SL Board
HD: 2x 320 Gb SATA on PCI-controller (onboard controller not working during installation)

During manual partition setup, I removed all existing partitions (linux ext3, swap, no raid partitions) on both disks, and created on each disk 3 partitions with type 'physical raid' as sda1-3 and sdb1-3. They showed up as '.. K raid .. '.

When I started 'Configure Software Raid', the partition tables were saved, but after selecting 'RAID1' I got an error message 'could not find any Linux Raid Autodetect' partitions'.

Changing the type to Linux extended and back to physical raid did not help. They showed up correctly in the partition editor, but were not detected by the software raid configuration. After changing the type to 'do not use', the partition showed up as 'Linux' in the partition list.

On the console, fdisk listed the correct partitions, but with type Linux. After starting the Configure Software Raid tool and manually changing the type of all partitions to 'fd' Linux RAID Autodetect', everything worked as expected (configuring the raid, installing onto the new raid partitions, rebooting,..)

Sorry, I did not test it with an older version of the installer, so I am not sure if this is a new bug in the partitioning tool or simply a fancy 'one-time broken-partition-table' bug (which would be my guess), because i simply was glad that it worked at all after some trouble with the onboard SATA controller and I had not much time :) (i think the kernel of the installer was too old for the onboard sata (seems to be a known bug) so we had to use a PCI controller; after booting into the newly installed 2.6.18 kernel, the onboard controller worked).

Stefan Hepp

--- End Message ---
--- Begin Message ---
Source: partman-md
Source-Version: 34

We believe that the bug you reported is fixed in the latest version of
partman-md, which is due to be installed in the Debian FTP archive:

  to pool/main/p/partman-md/partman-md_34.dsc
  to pool/main/p/partman-md/partman-md_34.tar.gz
  to pool/main/p/partman-md/partman-md_34_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 414203@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Frans Pop <fjp@debian.org> (supplier of updated partman-md package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 10 Mar 2007 17:53:26 +0100
Source: partman-md
Binary: partman-md
Architecture: source all
Version: 34
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Frans Pop <fjp@debian.org>
 partman-md - Add to partman support for MD (udeb)
Closes: 414203
 partman-md (34) unstable; urgency=low
   * Fix syntax error resulting in failure to set partition type.
     Closes: #414203.
 9b2437f5ea8af529057cecfd09aaf694 621 debian-installer standard partman-md_34.dsc
 659d986cfbec225bf20e009502b1776b 43645 debian-installer standard partman-md_34.tar.gz
 72bd37dc749a06fc93a9dcb1eb6192fb 29000 debian-installer standard partman-md_34_all.udeb
Package-Type: udeb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: