[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#414203: Installation problems: Wrong partition type for physical raid partitions

Package: installation-reports
Version: etch daily netinst 20070308 amd64

Machine: Dual Xeon on Intel S5000P SL Board
HD: 2x 320 Gb SATA on PCI-controller (onboard controller not working during installation)

During manual partition setup, I removed all existing partitions (linux ext3, swap, no raid partitions) on both disks, and created on each disk 3 partitions with type 'physical raid' as sda1-3 and sdb1-3. They showed up as '.. K raid .. '.

When I started 'Configure Software Raid', the partition tables were saved, but after selecting 'RAID1' I got an error message 'could not find any Linux Raid Autodetect' partitions'.

Changing the type to Linux extended and back to physical raid did not help. They showed up correctly in the partition editor, but were not detected by the software raid configuration. After changing the type to 'do not use', the partition showed up as 'Linux' in the partition list.

On the console, fdisk listed the correct partitions, but with type Linux. After starting the Configure Software Raid tool and manually changing the type of all partitions to 'fd' Linux RAID Autodetect', everything worked as expected (configuring the raid, installing onto the new raid partitions, rebooting,..)

Sorry, I did not test it with an older version of the installer, so I am not sure if this is a new bug in the partitioning tool or simply a fancy 'one-time broken-partition-table' bug (which would be my guess), because i simply was glad that it worked at all after some trouble with the onboard SATA controller and I had not much time :) (i think the kernel of the installer was too old for the onboard sata (seems to be a known bug) so we had to use a PCI controller; after booting into the newly installed 2.6.18 kernel, the onboard controller worked).

Stefan Hepp

Reply to: