[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#414117: [i386][netinst][daily 20070211] success: Dell PE1950, no raid

Package: installation-reports

Boot method: CD, with the command 'install'
Image version: Netinst daily image http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/i386/iso-cd/debian-testing-i386-netinst.iso, version 20070211-2.iso md5sum: 045f122cd20090fca10772c72f61ab57 Date: 2007-02-12

Machine: Dell PowerEdge 1950
         Dual Xeon CPUs, dual SATA hdd, no raid controller

System is configured with two identical disks in (software) RAID1
The first partition is /, is an ext3 partition.
The remainder is an LVM volume, with is sliced up further

# df -Tl
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/md0      ext3      482090    102625    354573  23% /
tmpfs        tmpfs     1038312         0   1038312   0% /lib/init/rw
udev         tmpfs       10240        92     10148   1% /dev
tmpfs        tmpfs     1038312         4   1038308   1% /dev/shm
              ext3     2064208     68680   1890672   4% /local
              ext3    10321208    154236   9642684   2% /srv/mysql
              ext3   154818540    192072 146762148   1% /srv/svn
              ext3     1032088     36580    943080   4% /tmp
              ext3     6192704   1535244   4342888  27% /usr
              ext3     4128448    299216   3619520   8% /var
              ext3    10321208    154244   9642676   2% /var/log/apache2
              ext3    10321208    154236   9642684   2% /var/www/vhosts

raw partition table:
# sfdisk -l /dev/sda

Disk /dev/sda: 30394 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1          0+     61      62-    497983+  fd  Linux raid autodetect
/dev/sda2         62   30393   30332  243641790   fd  Linux raid autodetect
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0          0    0  Empty

same for /dev/sdb

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [o]
Detect network card:    [o]
Configure network:      [e]
Detect CD:              [o]
Load installer modules: [o]
Detect hard drives:     [o]
Partition hard drives:  [o]
Install base system:    [o]
Clock/timezone setup:   [o]
User/password setup:    [o]
Install tasks:          [o]
Install boot loader:    [o]
Overall install:        [o]


System has two ethernet interfaces. Same type of device, just different MACs.
The installer consistently picked the "wrong" interface during installation -
i.e. the one that was not plugged in.
I tried a couple of i386 netinst installs, and one using the amd64 netinst.
Behaviour was consistent in all these cases.

I did try moving the ethernet cable to the other interface at the network
configuration stage, and got link-up messages etc. I moved it back to
complete the install because I was looking for further problems precipiated
by this.  This is likely the well-known problem with udev, and might be fixed
by the udev rules described in debian bugs #403706 and #405775.
I haven't tried this yet.

I answered 'no' to the "use network mirror" during apt-setup-udeb.
At the tasksel stage I selected "standard system" which added 9 packages.

On one occasion there was a hang while these packages were being copied from
the cdrom and installed. There was an error message from
apt-setup/generators/50mirror, and while all the dialogs indicated all the
packages were copied, it got stuck after or during the 6th.
However I was unable to reproduce this.

udev continues to give problems with disk renumbering; I would install
to a disk detected as /dev/sdb and reboot and the disk would now be named
/dev/sda. This needs to be documented in the release notes; its a significantly different behaviour from sarge.
I worked around this issue by putting the disks into an mdadm raid set;
this uses uuids to identify disks unambigously for udev and I get to use reasonably short device names in /etc/fstab. I decided to use LVM to give me flexibility in resizing partitions after installation (and multiple partitions are a pain).

The installer's default choices for this were reasonable but I dislike
having /boot as a separate partition; I would rather have all of / and
put /usr, /var /home and so on in separate partitions.

I followed (approximately) the paritioning and disk setup described by
http://dev.jerryweb.org/raid/ - I changed my mind several times about
the layout and redid it completely a number of times; partman soaked up
the punishment admirably.

The mdadm system for controlling the raid mirror also works well.
After installation, I was able to fail a disk, remove it and hot-add it back
with no problem.
I was also able to boot the system if the second disk was unplugged.
I could not boot with the first disk unplugged, this is a BIOS limitation.

Looking good!


Please make sure that the hardware-summary log file, and any other
installation logs that you think would be useful are attached to this
report. Please compress large files using gzip.

Once you have filled out this report, mail it to submit@bugs.debian.org.

Attachment: hardware-summary.pe1950.gz
Description: Binary data

Reply to: