[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#413931: marked as done (d-i missing ide modules)

Your message dated Thu, 08 Mar 2007 02:16:37 +0100
with message-id <200703080216.38161.elendil@planet.nl>
and subject line Bug#413931: d-i missing ide modules
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Boot method: CD
Image version: debian-31r5-i386-netinst.iso, from usc.edu mirror, md5sum good
Date: 7 Mar 2007, 22:00 UTC

Machine: Old Gateway, Tabor{2,3} motherboard
Processor: P3 (Katmai) 596MHz Memory: 384 MB ECC Partitions: none

Output of lspci and lspci -n: /bin/sh: lspci: not found
  dmesg says:
: PCI: Probing PCI hardware (bus 00)
: PCI: Using IRQ router PIIX/ICH [8086/7110] at 0000:00:07.0
: PCI: Found IRQ 9 for device 0000:00:07.0
: PCI: Sharing IRQ 9 with 0000:00:10.0

Base System Installation Checklist: [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked: [O] Configure network HW: [O] Config network: [O] Detect CD: [O] Load installer modules: [O] Detect hard drives: [O] looks correct in dmesg Partition hard drives: [ ] Create file systems: [ ] Mount partitions: [ ] Install base system: [ ] Install boot loader: [ ] Reboot: [ ]


Missing modules for ide.
Running as expert26 installation.
The last installer screen before starting disk partitioning says this:
: [.] Detect hardware
: Unable to load some modules
: Linux kernel modules needed to drive some of your hardware are not
: available yet.  Simply proceeding with the install may make these
: modules available later.
: The unavailable modules, and the devices that need them are: agpgart
: (Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge), ide-scsi
: (Linux IDE-SCSI emulation layer), ide-mod (Linux IDE driver),
: ide-probe-mod (Linux IDE probe driver), ide-detect (Linux IDE
: detection), ide-floppy (Linux IDE floppy)
:   <Continue>

Selecting Continue brings us to the start of partitioning and making

As I searched Google's archives of various debian lists for this problem,
the recurrent answer seems to be that this is an informative message only,
and the modules will be loaded later.  This seems to be contradicted by
this section from the Installation Guide:

: 6.3.2.B Partitioning and Mount Point Selection
: : At this time, after hardware detection has been executed a final time, : debian-installer should be at its full strength, customized for the : user's needs and ready to do some real work. As the title of this
:    section indicates, the main task of the next few components lies in
:    partitioning your disks, creating filesystems, assigning mountpoints
: and optionally configuring closely related issues like LVM or RAID : devices.

The text of the error screen, and the text of the Installation Guide,
seem to be saying clearly that these modules are needed to drive the IDE
hardware, and this was the last chance to automatically find them, and it
did not succeed.

I am _very_ reluctant to proceed to partitioning and file-system making,
for this reason:  A week ago I tried installing on this machine, using the
3.1R4 netinst CD and the original 4MB Seagate IDE disk that came with this
machine.  I saw the same errors about missing modules, but proceeded anyway.
The installer pretended to partition the disk, and pretended to install some
stuff for a while, then croaked with an error about the disk being Busy.
After much investigating of the disk with Knoppix and smartctl, it seemed
that the disk was permanently bad, giving errors on self-tests, unable
to successfully write to some parts of it, and hanging busy.  I replaced it
with 2 nice new high-capacity IDE Ultra-ATA disks, and downloaded the newest
netinst 3.1R5 CD, and tried again today.

I don't want to destroy my new disks by trying to partition them when the
installer is plainly telling me it doesn't have the necessary kernel modules
to do the job.  Is there some way I can supply these missing modules to
the installer ?  Should I try to partition/mk*fs them from Knoppix ?
Is there any other documentation I should read ?

Please advise.
Note: I am subscribed to the debian-bugs-dist list.

--- End Message ---
--- Begin Message ---
On Thursday 08 March 2007 02:06, Lou Poppler wrote:
> Yes, confusing and scary.  Perhaps the words "needed" and "need" are
> too strong in this message.  I leave this bug open only to allow
> d-i maintainers to consider if they want to reword it.

Well, you're not really supposed to install in expert mode unless there 
are specific reasons for that:-) It's normally really not needed anyway.

IIRC we've already removed this dialog for Etch anyway.

> Yes, thank you.  The CD part of the install finished fine, the disks
> are partitioned and OK, and now it has rebooted from the hard disk and
> is happily downloading more packages.

Great. Closing your report.


--- End Message ---

Reply to: