[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#413248: success with 'utf8' vfat mount option

Many thanks for the quick replies (including the info about #409516).

I've now tried the following vfat mount options:

(0) defaults (as generated by my oldish installer (weekly build 20070115))
(1) defaults,codepage=437 (this should be the default, so should be the same)
(2) defaults,codepage=850
(3) defaults,iocharset=UTF-8
(4) defaults,iocharset=UTF8 (just a hunch, but no good)
(5) defaults,utf8 (see mount(8) in the section 'Mount options for vfat')

Option (5) works for me; the others don't (details below).

Frans Pop wrote:
> Anyway, I doubt this would be an installer issue as there is no real way 
> for the installer to determine the correct settings.

Peter Green wrote:
> if so then imo this option should be set by the installer when generating
> fstab as afaict newly installed debian systems are completely utf-8 based
> nowadays.

Okay, if vfat option 'utf8' is the solution, perhaps the installer *should* 
set it when generating fstab? It doesn't seem so variable (and difficult to 
determine) as different codepage/iocharset things might have been.

It would be nice if this stuff worked 'out of the box'.  Much better than just
a comment in the release notes.  (Unless it does work with newer builds? I
should repeat that this is with the 20070115 build.) I still don't understand 
why I don't observe this problem on the box that I upgraded from sarge, as if 
the upgrade is incomplete somehow.  Is the reason that I haven't 'upgraded' 
the locale settings to utf-8? Or something deeper?

Anyway, details on the tests:

(0),(1),(2) the same problems as in the original report, for example:

   debian:~$ mount | grep hda1
   /dev/hda1 on /windows type vfat (rw,codepage=850)

   debian:~$ find /windows/windows/SendTo/ | wc
   wc: standard input:2: Invalid or incomplete multibyte or wide character
       7      17     315

(3),(4) the mount fails, for example:

   debian:/etc# mount /windows/
   mount: wrong fs type, bad option, bad superblock on /dev/hda1,
          missing codepage or other error
          In some cases useful info is found in syslog - try
          dmesg | tail  or so

   debian:/etc# dmesg | tail -2
   Unable to load NLS charset UTF-8
   FAT: IO charset UTF-8 not found

(5) success! so far, anyway... for example:

   debian:/etc# mount | grep hda1
   /dev/hda1 on /windows type vfat (rw,utf8)

   debian:~$ find /windows/windows/SendTo/
   /windows/windows/SendTo/3½ Floppy (A).lnk
   debian:~$ find /windows/windows/SendTo/ | wc
   7      17     316

   debian:~$ find /windows/windows/Favorites/ | grep Hifisound
   /windows/windows/Favorites/Hifisound der Lautsprecher Selbstbau Spezialist 
aus Münster.url

(final example: mkisofs now works; previously it aborted)

   debian:~$ mkisofs -r -J -o cdtest.iso /windows/windows/Favorites
   I: -input-charset not specified, using utf-8 (detected in locale settings)
   Total rockridge attributes bytes: 20387
   Total directory bytes: 14336
   Path table size(bytes): 86
   Max brk space used 22000
   387 extents written (0 MB)

Reply to: