[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GUI Not Functional After Errors Reading Installation CD's

Please CC me on replies.  Thank you.

While installing packages there were lots of errors reading the installation
CD's. Almost all flashed by too quick to see, but in the end, I got one
message that stayed long enough to read:

Errors were encountered while processing:

After that, I had no GUI, just a black screen and a prompt. This is my first
time ever using Linux so I just wanted to reboot and see if things were OK.
I think the command I used was "shutdown -r now". It did'nt reboot though. A
few messages flashed, then the screen went black. Finally I hit the power
button. On the next power-up, Debian booted into a very minimal GUI. I have
a mouse cursor, a colored screen, file manager, and a menu similar to the
Windows "Start" menu. That's all!

The whole process probably took over 5 hours, so redoing everything from
scratch would be my last resort.  I would really like to understand what
went wrong and how to fix it, so any suggestions would be very much

Everything went fine according to the installation guide until I was asked
what "Apt access method" I wanted. I selected "cdrom" because I have all 14
CD's (v3.1r1). Then I get the message:

This program was unable to autodetect a CD-ROM drive, or there is no usable
CD in the drive.

There was no CD in the drive because the installer had told me previously to
remove it. So I put CD1 back in and tried again - 4 times! I kept getting
the message:

hdd: irq timeout: status = 0xd0 {busy}
hdd: irq timeout: status = 0x00
hdd ATAPI reset complete

Some other messages flashed after that too. I thought maybe it was done with
the first CD so I put in CD2. Same error on the first try, but on the second
try, it read index files from it. Same with CD3 and CD4. Then I put CD1 back
in, and on the third try it read index files from there too. I let it read
index files from all 14 CD's. Most required two or three attempts (some
more), but all gave the above error at least once. Other messages filled the
screen but flashed too quickly to read. After each CD I was asked if I had
another CD "like the second of a 2 CD set". I was never asked to supply a
specific CD. I hope I did it right because none of this was in the
installation guide.

Also, I had a lot of problems getting it to read the CD's on the default
mount point of "/dev/cdrom", so I changed the mount point to "/cdrom"
because that's where the messages said it was mounted.

After the last CD the package installation screen came up and I accidentally
hit "Enter" instead of "Space", so nothing got selected. The installation
finished soon after that. I logged in as root. All I had was a black screen
and command prompt.

The installation manual says I can run "base-config" at any time, so I did
that. This time I selected Desktop environment, PostgreSQL and Manual
Selection. Next, I got what I think was "aptitude". I read all the stuff
that it was going to install, and I probably selected about 15 more packages
that looked interesting (or were "recommended" for packages already
selected). Then I hit "g" thinking it would ask for specific install CD's,
but it started downloading packages off the internet (a couple hundred I
think)! Why would it do that? When this finished, it asked for the "Binary
1" CD. I put in CD1. It took several tries to read it and there were lots of
errors. Then it asked for "Binary 2" CD. This had lots of errors on the
first attempt, but read OK on the second attempt. No more CD's were asked
for. What are the other 12 CD's for? This is when I got the message about
the four packages that had errors installing. Then I just had a black screen
and command prompt.

I thought maybe if I ran "base-config" again, it could fix the errors with
the four packages. This time I selected everything as before except "Manual
Selection". Screen messages showed about 100 packages being uninstalled -
including lots of stuff having to do with kde! I only added a handful the
last time I used "Manual Selection". Why was it uninstalling so much? This
is when I shut down with "shutdown -r now", but there was no reboot. I had
to turn off the power.

When I powered back up, things were as explained previously. I could'nt find
any shutdown dialog in the GUI, so after I logged out, my only option was to
log back in (I did as root). Then I had only the black screen again. I think
I used "shutdown -P now" to shut down and power off. That worked.

Reply to: