[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#394344: Bug#394340 (394344): missing IDE modules

Geert Stappers wrote:
Op 23-10-2006 om 09:50 schreef Jacob L. Anawalt:
I think I could install off of a CD image installer using all-generic-ide
if they were compiled in.

It could indeed that IDE modules are not loaded for your hardware.
When switching to VT2 is possible for you in d-i,
then I suggest that you manual `modprobe IDE-modules`.
(And please provide feedback.)

Trying modprobe IDE-modules from VT2 before the hardware detection scan:
FATAL: Module IDE_modules not found.

lsmod shows that ide_core is the only ide_* module loaded at this point.

Then I let hardware detection run. This loaded up ide_generic, ide_disk and ide_cd. IDE_modules is still not found, but I'm guessing you meant ide_* to get generic, disk and cd to load. I tried manually modprobing those modules, with little effect as they were already automatically loaded. If there is some module named IDE_modules, it does not exist on that installer in a location that `modprobe IDE-modules` would work.

This is the same installation CD I used in October. The help text before booting the installer (F1) says 20061019.

I apologize for the large delay but the system I was testing on before was put into production and has not been able to be taken offline since. I have since purchased identical hardware for a backup of the system and am testing again. I am still of the opinion that all-generic-ide must be compiled in for this to work. I have not seen a post on the web to the contrary, instead I see more about work-arounds like sata cd-rom drives and USB installs.


Reply to: