[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Please allow discover-data 2.2007.01.21 to propagate into Etch

Please allow discover-data version 2.2007.01.21 to propagate into
etch.  It corrects X detection for a bunch of cards, as well as some
minor kernel module updates and minor updates on busclass and
recognized device names.

Here is the changelog:

discover-data (2.2007.01.21) unstable; urgency=low

  * Update HW mappings for PCI devices:
      10de0044, 10de0046, 10de0047, 10de0048, 10de0090, 10de0091,
      10de0092, 10de0093, 10de0095, 10de0098, 10de0099, 10de009d,
      10de00c3, 10de018c, 10de018d, 10de01d1, 10de01d3, 10de01d6,
      10de01d7, 10de01d8, 10de01d9, 10de01da, 10de01db, 10de01dc,
      10de01dd, 10de01de, 10de01df, 10de0218, 10de0240, 10de0241,
      10de0242, 10de0244, 10de0247, 10de0290, 10de0291, 10de0292,
      10de0298, 10de0299, 10de029a, 10de029b, 10de029c, 10de029e,
      10de029f, 10de0391, 10de0392, 10de0393, 10de0394, 10de0395,
      10de0397, 10de0398, 10de0399, 10de039a, 10de039b, 10de039c,
      10de039e: nv X driver, based on the nv_driver.c source.
      80863575: agpgart [2.4->2.6), intel-agp [2.6->) based on
                currently loaded modules on a Thinkpad X30.
      11063118: via X driver.  Based on via_driver.c source.

 -- Petter Reinholdtsen <pere@debian.org>  Sun, 21 Jan 2007 16:24:28 +0100

discover-data (2.2007.01.20) unstable; urgency=low

  [ Petter Reinholdtsen ]
  * Mark all PCI devices using i2c-i801 as bustype 'bridge'.
  * Replace '(lspci -n; lspci)|sort' in reportbug scripts and use
    'lspci -nn' instead.  This require pciutils >= 1:2.2.4, add
    recommends to document this.
  * Update the name of some busclasses in pci-busclass.xml to match
    the pci.lst values.
  * Add PCI busclass 0805 (Generic system peripheral) using
    miscellaneous as the keyword used in pci.lst.
  * Add video busclass to a few nvidia devices.
  * Update pci-vendor.xml, pci-devices.xml, pci.lst and pci-26.lst
    from http://pciids.sourceforge.net/pci.ids.gz.
  * Update HW mappings for PCI devices:
     8086:2653: ata_piix[2.6.15->) based on the new reportbug script
     and my laptop.
     10de029d: nv X driver. (Closes: #407138)
     80862992 and
     808629a2: i810 X driver, based on the i810_driver.c
               source. (Closes: #407103)

 -- Petter Reinholdtsen <pere@debian.org>  Sat, 20 Jan 2007 13:28:15 +0100

This change is related to d-i as discover-data contain an udeb (used
in beta3 and not in rc1, I believe, but not sure), but do not contain
any changes that should affect d-i negatively.  CC to debian-boot to
have this confirmed.

Petter Reinholdtsen

Reply to: