[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#406620: R: Bug#406620: user-setup: Failed to ask its questions when run during default install

I'm out of office until wednesday... 
I don't know when the server will go into production, so i'm not sure how many tests we can do, at the moment it's still a clean install and it will probably need to be reinstalled as debian 3.1 (using HPDE installers) so i think i should have the time to retry the 4.0 RC1 install... 
As to partitioning: the disks were already partitioned due to earlier tests with sarge, i just assigned the mount points, tried to run the installer and it told me i had an already installed system (installing on an unclean system could lead to problems blah blah), i then went back to partitioning and chose the format partition option for all partitions i created an installed.
Hope this gives a bit extra info. 
Please let me know what could be required as testing should i reinstall. Simply reinstall as i did this time? anything particular to look at? 
Thanks, Luca


Da: Frans Pop [mailto:elendil@planet.nl]
Inviato: ven 12/01/2007 19.09
A: Benelli Luca; 406620@bugs.debian.org
Oggetto: Bug#406620: user-setup: Failed to ask its questions when run during default install

reopen 406620
reassign 406620 user-setup 1.7
retitle 406620 user-setup: Failed to ask its questions when run during default install

On Friday 12 January 2007 17:21, Benelli Luca wrote:
> I don't know if you want to consider this as an issue or not... I just
> noticed.

Well, it _is_ a very important issue if it is correct...

> Attached find the gzipped installer syslog.
> At Jan 12 06:04:51 an adduser error and a passwd error occur.... Hope
> it helps.

The relevant bit is a bit earlier:
Jan 12 05:13:00 main-menu[2078]: INFO: Menu item 'user-setup-udeb' selected
Jan 12 05:13:01 main-menu[2078]: INFO: Falling back to the package description for auto-install

This shows that user-setup _was_ run and it appears to have run without
errors. At this point you really should have been asked the questions
about root passwords and user account.
The next log item shows that user-setup completed almost immediately.
Certainly too fast to have you answer its questions...

However, there is no indication at all of what may have gone wrong.
I've tried some things to see if I could reproduce the behavior, but I
cannot. If the questions were indeed not asked, that explains the later
error you pointed out.

Jan 12 05:13:01 main-menu[2078]: INFO: Menu item 'base-installer' selected
Jan 12 05:13:08 base-installer: error: exiting on error base-installer/unclean_target_cancel
Jan 12 05:13:09 main-menu[2078]: WARNING **: Configuring 'base-installer' failed with error code 30
Jan 12 05:13:09 main-menu[2078]: WARNING **: Menu item 'base-installer' failed.

This shows that at least something weird happened during your installation.
Did you make a mistake during partitioning?
However, normally that should not affect the way users are set up.

As this is the first time this has been reported, I'm inclined to treat it
as a fluke. I'm still reopening the report and reassigning it to the
relevant component as IMO it should be available for reference for a while.

It would be great if you could try to reproduce this. In that case we can
try some additional debugging.

Thanks for providing the additional information.



Reply to: