[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#404435: Debian etch RC1 does not start

(Please don't use too fancy indentation; makes it harder to reply)

On Sunday 24 December 2006 20:23, Willem Weide wrote:
> Description:
> I use lilo on hde1 as the primary bootloader. From here I point to one
> of the four OS's listed above. 
> Before RC1 I worked with beta 2 and 3 images on hdh1 and they worked
> very well. 
> Selecting debian etch from the lilo menu, gives me a message "..GRUB.."
> at the top of the screen for less then a second. After that the system
> reboots directly.

You seem to have an fairly uncommon setup. I assume you've set lilo to 
chainload into hdh1 and have installed grub there.
You also seem to have done some things manually, which makes it difficult 
to anticipate the setup. Your best chance is to try to identify the 
problem yourself. Hopefully this will help.

Are you sure that your BIOS supports booting hdh? What happens if you 
select hdh as primary boot device?
Does your BIOS have the same idea of the order of devices as Debian had 
during the install (see also my last remark)?

AFAIK, it should also be possible to configure lilo to directly load the 
Etch initramfs and kernel (hmm, maybe not across disks). Why not do that?
Why not use grub as your primairy bootloader? It really is much more 
flexible for setups like yours.

Have you checked the grub configuration on hdh and tried reïnstalling it?
You can use the "rescue mode" of the installer to do this (see boot help 
screens and installation guide).

With your setup, you should also be aware of the first erratum listed on:
However, you don't seem to be at that stage yet, though it _could_ be 
involved it grub's /boot/grub/device.map was setup incorrect.


Reply to: