[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

boot failure on powerpc newworld, imac g3


this didn't make it to the lists, but it's in the bts as #394209, please reply 
to 394209@bugs.debian.org - thanks.

Package: installation-reports
severity: important

Boot method: netinstall-cd and netboot-cd images

Image version: 2006-10-19 from 
and http://people.debian.org/~wouter/d-i/powerpc/daily/ (this one being the 
latest, built on the 19th, 22:53) plus beta3 and beta2

Date: 2006-10-19, 2006-10-20

Machine: imac g3, tray-loading cd R32)>

processor       : 0
cpu             : 740/750
clock           : 233MHz
revision        : 2.2 (pvr 0008 0202)
machine         : iMac,1
motherboard     : iMac MacRISC Power Macintosh
detected as     : 65 (iMac (first generation))
pmac flags      : 00000000
L2 cache        : 512K unified
memory          : 32MB
pmac-generation : NewWorld

        #                    type name                length   base    
( size )  system
/dev/hda1     Apple_partition_map Apple                   63 @ 1       
( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap bootstrap             1600 @ 64      
(800.0k)  NewWorld bootblock
/dev/hda3         Apple_Bootstrap linux              7782400 @ 1664    
(  3.7G)  NewWorld bootblock
/dev/hda4         Apple_UNIX_SVR2 swap                634752 @ 7784064 
(309.9M)  Linux swap

Block size=512, Number of Blocks=8418816
DeviceType=0x0, DeviceId=0x0

Output of lspci and lspci -n:

00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
00:10.0 Class ff00: Apple Computer Inc. Paddington Mac I/O
00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC 215IIC 
[Mach64 GT IIC] (rev 3a)
00:14.0 USB Controller: OPTi Inc. 82C861 (rev 10)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


beta2 (and the sarge installer) work well, but neither the dailies nor beta3 
boots. Screenshots attached. (Both are after selecting install, expert or 
rescue.) The dailys fail with:

RAMDISK: Compressed image found at block 0
RAMDISK: ran out of compressed data
Invalid compressed format (err=1)
No filesystem could mount root, tried: cramfs
Kernel panic - not syncing: VFS: Unable to mount roos fs on unknown-block(1,0)

I'm not making this serious atm, as I have seen beta3 booting successfully on 
a g4 powerbook...

BTW, booting fails slightly different, after uprading a sarge system to etch, 
no matter if I use a 2.6.17 (from etch) or .18 kernel (from sid). Screenshot 
also attached.


[beta3.png (image/png, attachment)]

[daily.png (image/png, attachment)]

[etch-upgrade.png (image/png, attachment)]

Attachment: pgpuXCBWUjiV2.pgp
Description: PGP signature

Reply to: