[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#393786: installation-reports: sparc32 failure

Package: installation-reports

Boot method: CD
Image version: 20061017, cdimage.debian.org etch daily sparc netinst
Date: 20061017 20:00 GMT+0300

Machine: Sun SparcStation 5
Processor: 170 MHz TurboSparc
Memory: 256M
Partitions: 1 520M SCA SCSI HDD, known working (2 year old Linux installation booted fine). 1 SCSI CDROM on the same bus.

Output of lspci and lspci -n:
N/Am this is a SBus machine. It has onboard ESP SCSI and le dma, 2 SBus CG6 graphics cards are the only non-integrated components.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [E]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


When I tried with keyboard attached and used framebuffer interface, I got different ESP SCSI errors both times - dmesg below (yay for netcat!). I also tried one time with serial console and SCSI worked fine but I got CD mount errors.

First time with FB, SCSI errored out and no SCSI device was accessible. This try was not captured since I was not prepared.

The try with serial console did detect both SCSI devices fine but failed to mount CD. Digging around showed that iso 9660 filesystem was not available in /proc/filesystems and could not be modprobed either

The second try with framebuffer gave the SCSI error again and this time I managed to copy dmesg using netcat. This time SCSI HDD errored out but CD was detected and could not be mounted like before. dmesg of this try:

PROMLIB: Sun Boot Prom Version 3 Revision 2
Linux version 2.6.16-2-sparc32 (Debian 2.6.16-17) (waldi@debian.org) (gcc version 4.0.4 20060630 (prerelease) (Debian 4.0.3-4)) #1 Sat Jul 15 22:25:28 BST 2006
TYPE: SPARCstation 5
Ethernet address: 8:0:20:90:36:e5
Boot time fixup v1.6. 4/Mar/98 Jakub Jelinek (jj@ultra.linux.cz). Patching kernel for srmmu[Fujitsu TurboSparc]/iommu
63MB HIGHMEM available.
On node 0 totalpages: 63989
  DMA zone: 47703 pages, LIFO batch:15
  DMA32 zone: 0 pages, LIFO batch:0
  Normal zone: 0 pages, LIFO batch:0
  HighMem zone: 16286 pages, LIFO batch:3
Power off control detected.
Built 1 zonelists
Kernel command line: root=/dev/ram cdrom ramdisk_size=16384 console=ttyS0,9600 console=tty0
PID hash table entries: 1024 (order: 10, 16384 bytes)
Console: colour dummy device 80x25
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 250420k/261752k available (1596k kernel code, 11132k reserved, 376k data, 140k init, 65144k highmem)
Calibrating delay loop... 169.16 BogoMIPS (lpj=845824)
Mount-cache hash table entries: 512
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 3478k freed
NET: Registered protocol family 16
IOMMU: impl 0 vers 5 table 0xf32c0000[262144 B] map [65536 b]
sbus0: Clock 21.1250 MHz
dma0: Revision 2 dma1: Revision 2 ioremap: done with statics, switching to malloc
apc: power management initialized
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered (default)
io scheduler deadline registered
io scheduler cfq registered
Console: switching to colour frame buffer device 144x56
cg6: CGsix [TGX+ sparc] at 0:40000000
cg6: CGsix [TGX+ sparc] at 0:50000000
SunZilog: 2 chips.
zs2 at 0xfd417004 (irq = 44) is a SunZilog
zs3 at 0xfd417000 (irq = 44) is a SunZilog
ttyS0 at MMIO 0x0 (irq = 44) is a SunZilog
Console: ttyS0 (SunZilog zs0)
ttyS1 at MMIO 0x0 (irq = 44) is a SunZilog
Floppy drive(s): fd0 is 1.44M
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
rtc_sun_init: Registered Mostek RTC driver.
mice: PS/2 mouse device common for all mice
NET: Registered protocol family 2
IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
TCP established hash table entries: 8192 (order: 3, 32768 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
TCP reno registered
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 140k freed
input: Sun Type 5 keyboard as /class/input/input0
sunlance.c:v2.02 8/24/03 Miguel de Icaza (miguel@nuclecu.unam.mx)
SunLance: using auto-carrier-detection.
eth0: LANCE 08:00:20:90:36:e5 SCSI subsystem initialized
esp0: IRQ 36 SCSI ID 7 Clk 40MHz CCYC=25000 CCF=8 TOut 167 NCR53C9XF(espfast)
ESP: Total of 1 ESP hosts found, 1 actually in use.
scsi0 : Sparc ESP100A-FAST
  Vendor: SEAGATE   Model: ST5660N  SUN0535  Rev: 0638
  Type:   Direct-Access                      ANSI SCSI revision: 02
esp0: target 3 [period 100ns offset 15 10.00MHz FAST SCSI-II]
SCSI device sda: 1065664 512-byte hdwr sectors (546 MB)
sda: Write Protect is off
sda: Mode Sense: c2 00 00 08
  Vendor: TOSHIBA   Model: XM5701TASUN12XCD  Rev: 0997
  Type:   CD-ROM                             ANSI SCSI revision: 02
SCSI device sda: drive cache: write through
SCSI device sda: 1065664 512-byte hdwr sectors (546 MB)
sda: Write Protect is off
sda: Mode Sense: c2 00 00 08
SCSI device sda: drive cache: write through
 sda: sda1 sda2 sda3
sd 0:0:3:0: Attached scsi disk sda
esp0: target 6 asynchronous
esp0: Aborting command
esp0: dumping state
esp0: dma -- cond_reg<a4400010> addr<f000d002>
esp0: SW [sreg<10> sstep<04> ireg<20>]
esp0: HW reread [sreg<10> sstep<c4> ireg<00>]

esp0: disconnected esp0: Resetting scsi bus
esp0: SCSI bus reset interrupt
esp0: SCSI bus reset interrupt
sd 0:0:3:0: scsi: Device offlined - not ready after error recovery
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.20
sr 0:0:6:0: Attached scsi CD-ROM sr0

Meelis Roos (mroos@linux.ee)

Reply to: