[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#391483: partman-md: Deleting md devices doesn't work.

Package: partman-md


I've done an netinst installation on an amd64 with the etch beta 3
(20060806) version.

It seems that deleting md devices doesn't work.  If I select delete md
device, it's still showing up as md device.  You can't configure it or
anything, doesn't have a size and things like that.  I think at that
point it also gives a warning about an unknown size.

After a failed installation where I created 2 md devices and it failed
to boot, I tried removing the first md devices that had /boot on it, to
create a normal partition to see if I could boot from that.

Since it now was acting strange when I deleted the md device, I've also
removed the second devices, at which point it showed those 2 raid
devices in a weird state.  I then created a new md device with the same
partitions as my original second md device had.

I've only changed the raid partition of the first disk to to a normal
partition with an ext2 filesystem.

I believe that at that point when it was rescanning the disks, I saw
some strange error messages that I didn't write down and can't remember
exactly.  But it seems that sdb1 and sdb2 had the same uid or something,
and that it selected sdb2 instead of sdb1 because sdb1's size didn't
match.  Or atleast that's what I think the message tried to say.

I might have seen that error message after another reboot or something,
I'm not really sure at what point in my installation attempt I saw that

I assume that the error message is because md0 still had the same uid,
and that I've used an other disks for it now.  It would be nice if I
deleted an md device, the uids on the partitions in it would be cleared


Reply to: