[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation Report: etch beta 3 on Asus P5LD2-VM: *FAILED*

Hash: SHA1

Hi list,

I tried to install Debian etch with the beta 3 netinstall image on an
Asus P5LD2-VM board with a Dual Core Intel CPU, Intel 945G Northbridge
and Intel ICH7 Southbridge.

The machine came with an SATA HD and an IDE DVD ROM.
The install failed because the CD could not detect the DVD drive.
It appeared that the SATA driver (ata_piix) was loaded before the legacy
IDE drivers. Because the ICH7 southbridge provides both, SATA and IDE,
but with the same IO and IRQ, it happened, that the kernel complained
the the IO was already in use and the legacy IDE driver could not be loaded.

I tried to install Redhat Enterprise 4 (kernel 2.6.9): it could load the
modules in the correct order (i.e. IDE first, then ata_piix) and detect
the IDE drive before the SATA HD and install successfully. However, the
NIC failed, because the kernel was obviously too old for the newer
Gigabit adapter (e1000 driver).

So, I tried t install Knoppix (v. 5.0.1) which comes with kernel 2.6.17.
This one also detected the IDE drive before the SATA HD and also the NIC
was no problem. Installation went smooth, so I installed Knoppix and
then upgraded the packages to the latest testing and removed those
packages I didn't need.

After reboot with the current 2.6.17 kernel from testing, also no
problems occurred.

So, two things:
1. upgrade the kernel to the current 'testing' version
2. make sure the IDE drivers get loaded before ata_piix

- --
Arne Götje (高盛華) <arne@linux.org.tw>
PGP/GnuPG key: 1024D/685D1E8C
Fingerprint: 2056 F6B7 DEA8 B478 311F  1C34 6E9F D06E 685D 1E8C
Key available at wwwkeys.pgp.net.   Encrypted e-mail preferred.

Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: