[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#387897: Installation report


At the first time I used Loop-aes. I think I used the random key in that time as I wasn't going to use any keyfiles. After I noticed I couldn't create LVM-partitions with it I decided to change to dm-crypt. I rebooted and retried to create the partitions and used the dm-crypt on this time. Because the wiping takes a lot of time, I skipped it. I used the passphrase this time but this time the problem occured. When I encrypted one partition, I tried to create lvm-partition on it. I think this somehow removed the encryption as it vanished from the menu and the lvm stayed in there. Again, I removed the partitions and exited the installer to begin a new to find a some solution. After this I tested all kind of configurations but after it has asked the passphrase and would have started to write these encrypted partitions on disk it always gave the same error. I'm not 100% sure but it might have given a error about partition already being in use or something.

Unfortunately I can't remember the exact error messages anymore.

The problem is probably something in the installer itself as I installed a minimal setup with no problems and then booted into it and created the encrypted partition and lvm2-partitions over it without any problems.

Hope this information is helpful

Timo "Zmyrgel" Myyrä

Max Vozeler kirjoitti:
Hi Timo,

On Sun, Sep 17, 2006 at 12:44:04PM +0300, Timo Myyrä wrote:
I had troubles with the crypting my harddrive. It just said that error happened. I could choose the encryption and all but when I was supposed to write them to disk it started complaing about error. This happened after it asked the passphrase. Also, I couldn't create LVM-partitions on the encrypted partition. I tried both, dm-crypt and the loop-AES. Unfortunately I don't have the logs anymore. I checked the partman log when trying encryption and it said something like following: "/lib/partman/choose_partitions/35crypto/do_option: cryptsetup failed" Encryption seemed to work the first time when I wiped the partition and tested it but I couldn't make the partitioning I wanted so I exited the installer and booted to retry
but it wouldn't work anymore.

Do you remember if one or more of the partitions were configured to use a random key ?

I'm asking because there is a known problem with using random key encryption in the GUI installer. This affects both normal
loop-AES partitions with "keyfile" key and dm-crypt partitions
with "random" key. Those cannot be setup using the GUI installer
because a component required for those configurations is not
available for the gtk frontend.

On the other hand, you said it showed a normal error dialog, so
maybe this was actually caused by something different. If the
problem was indeed the missing component, it should have shown an
error dialog saying "tools missing for encryption", instead of
simple "an error occured".

I will try to reproduce this problem. David, maybe you have an
idea what might have gone wrong?


Reply to: