[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#386752: cdebconf-gtk-udeb: Probably not enough memory allocated for string



On Sunday 10 September 2006 10:44, Attilio Fiandrotti wrote:
> Aike has spotted a bug that would have been difficult to catch, in fact
> this would have shown up only when booting in rescue mode and using
> recent (2.8.21) GTKDFB libraries.

Yes, excellent catch.

> There are a couple of places in the GTK frontend where i check for GTK
> version, and this is because i once used to compile it against GTK
> 2.8/2.9 while 2.0.9 was used in the d-i.
> Now that d-i has switched to 2.8.x, there would be no longer need for
> version check: should i remove the version checks so that compiling the
> GTK frontend against old GTKDFB 2.0.9 will simply fail?

I talked to Davide on IRC yesterday and he told me that 2 of the RC issues 
[1] are fixed in new 2.10.x libs but may be hard to backport to 2.8.x.
As long as we do not have definite confirmation from Gnome/GTK team that 
they will go with 2.10.x for Etch and these issues are not fixed in 
2.8.x, I'd like to keep 2.0.9 open as an option [2].

[1] I'm talking about the blue lines and the disappearing selected line in
    selection lists.
[2] Although that may be difficult with cairo using newer directfb...

Attachment: pgpi0YMwPK3kK.pgp
Description: PGP signature


Reply to: