[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#352914: fixed in yaboot-installer_1.1.7 ?

On Fri, Sep 08, 2006 at 09:55:43AM +0200, Holger Levsen wrote:
> resent, as I forgot to cc: the submitters..

Please mention the bugs in the body, as this was also confusing.

> Hi,
> yaboot-installer_1.1.7 was uploaded three days ago and fixed #375505 and 
> #377098 which look quite similar to these bugs - could you please try again 
> with a new daily build from sid and see if the bug still exists?
> From the changelog:
>    * Only write  magicboot= line on NewWorld PowerMacs (closes: #375505).
>    * If ofpath returns nothing, try leaving out the device= line in the hope
>      that yaboot will figure it out (it's better than writing an unparseable
>      configuration file; see #375505).
>    * Write appropriate console=hvc* into append= line if using an HVC virtual
>      serial console (closes: #377098).

Ok, ...

I believe both of these bugs may have been fixed, but yaboot-installer still
needs some work.

   #332227 yaboot-installer: install fail on open power 710

   Xavier Grave did a recent install, which went mostly well. I am not sure
   his work can confirm the yaboot-installer fix, since base-installer not
   knowing about power5+ cpus meant he had the wrong kernel installed, but he
   mentioned it being fixed by hand-installing said kernel, and rerunning

   #352914 yaboot-installer tries to search for apple partitions on ibm rs6k/pseries hardware

   This one i think is solved.

Anyway, i did an install on a pSeries p505 with a power5 cpu, and it did
install yaboot just fine, altough there are three issues there :

  1) ofpath returned nothing. The right fix to this is for yaboot-installer
  not to use ofpath, but the new ofpathname, which is much nicer, maintained
  upstream, and in general the thing to use for the future. It is part of the
  powerpc-utils (not the package in debian of the same name) at : 
  The device= line is needed if the kernel and co are not found on the same
  device/disk as the prep partition, otherwise it works just well without it.

  2) yaboot is broken on IBM chrp/pseries hardware. it has no idea on how to
  find the partition where the /etc/yaboot.conf is, and thus does a search for
  it on all partitions of the disk, starting from the last one. The problem is
  that altough all filesystem methods fail to find it, the of method does read
  32K of garbage somewhere and claims it is ok, thus yaboot selects the last
  partition of the disk as the one holding the yaboot.conf. This can be worked
  around by ensuring that / or /boot is the last partition of the disk.

  3) if a separate /boot is used, probably because some special thing is used
  for /, like LVM or RAID or whatever, that the firmware/yaboot cannot boot
  from, then both yaboot and the /etc/yaboot.conf need to be copied to the
  /boot partition.

Hope this helps, 


Sven Luther

Reply to: