[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#379637: Package: installation-reports

On Mon, Jul 24, 2006 at 12:34:58PM -0400, Miles Fidelman wrote:
> Package: installation-reports
> http://cdimage.debian.org/debian-cd/3.1_r2/i386/iso-cd/debian-31r2-i386-netinst.iso
> Disk /dev/sda: 400.0 GB, 400088457216 bytes
> Disk /dev/sdb: 400.0 GB, 400088457216 bytes
> Disk /dev/sdc: 400.0 GB, 400088457216 bytes
> Disk /dev/sdd: 400.0 GB, 400088457216 bytes
> raid set up as follows:
> md3 : active raid1 sdb5[0] sdc5[2] sdd5[1]
>       195310080 blocks [2/2] [UU]
> md0 : active raid1 sda1[0] sdb1[2] sdc1[1]
>       979840 blocks [2/2] [UU]
> md2 : active raid1 sdb3[2] sda3[0] sdc3[1]
>       97659008 blocks [2/2] [UU]
> md1 : active raid1 sda2[0] sdb2[2] sdc2[1]
>       2634560 blocks [2/2] [UU]
> /dev/md0 mounted as /boot (ext3)
> /dev/md1 allocated for swap
> /dev/md2 allocated as LVM pv /dev/rootvolume
> /dev/md3 allocated as LVM pv /dev/backupvolume
> Output of lspci and lspci -n:
> server1:/etc# lspci
> server1:/etc# lspci -n
> Base System Installation Checklist:
> [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> Initial boot worked:    [O]
> Configure network HW:   [O]
> Config network:         [O]
> Detect CD:              [O]
> Load installer modules: [O]
> Detect hard drives:     [E]
> Partition hard drives:  [E]
> Create file systems:    [O]
> Mount partitions:       [O]
> Install base system:    [E]
> Install boot loader:    [E]
> Reboot:                 [E]
> Comments/Problems:
> Detect Hard Drives:
> - default kernel (2.4) couldn't detect drives
> - needed to run linux26/expert26 to detect SATA drives - then worked ok


> - could use a little better documentation

Which documentation did you use? (Which documentation should be improved?)

> Partition Hard Drives:
> - this was VERY time consuming and error prone
> - I was using the combination of md and lvm, which is very poorly 
> documented, and doesn't work completely (at least for sarge)

Oh, now I see the 3.1 that was told before.
That I explains the default of a 2.4 kernel.

> - things I discovered along the way:
> ---- after specifying a RAID set, things work badly unless you wait for 
> the disks to sync (alt-f2, watch and wait, for each raid set - wait a long time)

You where waiting for about 800 GIGA Byte to be transferred,
that does take time.

> ---- after creating raids and trying to write them, I got errors along 
> the lines of note: "unable to re-read the partition table, you should 
> reboot" - turns out that it's ok to ignore these, but you have to go 
> into and out of the partition editor a couple of times to move on to the 
> next step of configuring LVM
> ---- create file systems worked after figuring out the md and lvm setups
> - the documentation needs a lot of work for this. some suggestions:
> -- sections and .3 should be reversed (setting up RAIDs needs to 
> happen before setting up logical volumes!)
> -- need a lot more discussion about complex setups (lvm over raid, and 
> so forth) - I found 
> http://www.planamente.ch/emidio/pages/linux_howto_root_lvm_raid.php
> to be the best resource - suggest either adding a link, or incorporating 
> text from it


> Install boot loader and reboot:
> - neither lilo nor grub set up properly after the disk partioning
> - got errors about not being able to install (tried a lot of different locations)
> - had to use the install disk as a rescue disk to boot and figure out 
> the proper paths to the kernel and initrd
> - it seemed to get grub into the MBR on one hard drive, so I was able to 
> reboot - which got me into grub
> - manually booted via grub
> - manually installed grub into MBRs of other disks
> - had to set up menu.lst manually
> - then everything pretty much worked

I read that the LVM & RAID stuff wanted more attention then expected.
Reading the changelog of 

> A few more nits that I had to clean up manually:
> - the -386 kernel only recognized 1G of 3G: I had to install a -686 
> version of the kernel and reboot to see all my memory (might want to add 
> more kernel choices to the installer and/or put some notes in sec. 3.6.4 
> of the installation manual regarding what to do if you don't see all 
> your memory - all that's mentioned now is to try using the mem= kernel 
> option, which doesn't help)

The "netinst CD" has only one kernel, a i386 that (tries to) fits all.
Other install methods present more kernels. There is -686 available.

> - the installer did not quite get swapping or the fstab right, I had to
> > mkswap/dev/md1
> > swapon
> and add the following to fstab:
> /dev/md0        /boot           ext3    defaults        0       0
> /dev/md1        none            swap    sw              0       0

I think it doesn't make sense to swap to a RAID device.

> and there seems to be some kind of subtle bug or interactions in the 
> raid code:
> I have spare devices configured for each raid, but they didn't show up 
> on initial boot.  As best as I can reconstruct from the boot logs:
> /dev/md0 - which mounts as boot, tried to bind it's spare device, and 
> then kicked it out as being out of date.  I did a manual
> mdadm /dev/md0 -a /dev/sdb1
> and it mounted cleanly, and then automounted on subsequent reboots.
> /dev/md2 - which mounts as / - would not mount it's spare device at all, 
> and there's no indication in the boot log that it even tries.  I finally 
> gave up and put a crude work-around, by executing "mdadm /dev/md2 -a 
> /dev/sdb3" in a locally defined init file (executed via rcS.d).
> One last suggestion: it might be worth enabling bootlog to be on by 
> default - it would make debugging a lot easier, rather than first having 
> to figure out that it exists and then how to turn it on.

Mmm, I can see the advantage of it. (But not the disadvantage)

> Overall: not a complete snap, but given that mine is a somewhat 
> complicated setup, and I'm coming at this from a Solaris and Red Hat 
> background, I'd consider this a reasonably smooth setup.

Thank you for the compliment.

> Now I'm off to load and configure application software and migrate apps 
> from my old Red Hat box (and not completely happy that Debian uses Exim 
> instead of Sendmail by default, sigh...).

apt-get install postfix

Geert Stappers

Reply to: