[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#375208: ppc oldworld miboot-floppies daily-build status



package: installation-report

Hi,

I tested the daily-build from 
http://people.debian.org/~cjwatson/d-i/powerpc-miboot/2006-06-21/powerpc/floppy/
on an oldworld powermac 4400 with lowmen (48mb IIRC) and noticed some problems 
and a failed installation.

The etch floppies from 
http://ftp.nl.debian.org/debian/dists/testing/main/installer-powerpc/beta2/images/
didnt work (boot-floppy didn't boot), I guess because they are build without 
the non-free miboot tool. It would be nice, if for beta3 we could point 
people to working images. (Which I haven't found for beta2.)

After booting the boot.img from june 21st (which worked fine so #345467
can be closed) I noticed that I need to eject it manually, before I could 
insert the root-floppy. IIRC this is a regression, and we had ejecting 
boot-floppies. 

After writing a floppy image on a floppy, I compare them with /usr/bin/cmp. 
"cmp: EOF on root.img" is known for a while (#295996), whats new is that I 
get the same error with the cd-drivers.img now as well.

The net-drivers.img is too big to fit on a floppy! :-(

I downloaded and used the CD image I used from
http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/powerpc/iso-cd/debian-testing-powerpc-netinst.iso 

Next problem was the auto-partioning, in Partition disks: it defaults to 
floppy :(

So far I avoided LVM and choose the non LVM setup. (So I cannot say if #267992 
and #279118 are fixed)

Then the installation runs without problems until quik-installer, this
ends with an error because /boot is on a seperate partition (though quik 
supports it, the error-msg (typed not copied) is: "the quik bootloader 
requires /boot to be on the same partition as /"
(#264815 are #266123 (essentially fixed, otherwise the above would not 
happen :) are related to this. )

Even when this is fixed, the machine will not boot, cause some OF variables 
need to be set, see #274115.



So my todo-list is:
1. close #345467 (root.img doesnt work)
2. clone this bug to have one as a reminder to have beta3 miboot images 
somewhere - should I also reassign/usertag it? 
3. clone this bug and rename to "net-drivers.img to big to fit on a floppy"
4. send mail to #295996 indicating that cd-drivers.img is know also affected
5. clone this bug, reassign to ??? and rename to "partioning defaults to 
floppy drive when booting from floppy"
6. clone this bug, reassign to quik-installer and rename to "/boot on a 
seperate partition is ok", try to fix it
7. add powerpc usertag for user debian-boot@lists.debian.org to this bug and 
the cloned ones.
8. "monitor" #267992, #279118 (both lvm related) and #264815, #266123 (quik 
ext3 related), and #274115, #369304 (quik OF related)


regards,
	Holger

Attachment: pgpbDRt7SKtpT.pgp
Description: PGP signature


Reply to: