[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#349636: marked as done (preseed/early_command is not working with initrd preseeding)

Your message dated Mon, 19 Jun 2006 15:47:21 -0700
with message-id <E1FsSWf-0007v5-HY@spohr.debian.org>
and subject line Bug#349636: fixed in preseed 1.17
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Boot method: floppy + usbflashstick containing netinst iso & hd-media
initrd  modified with preseed.cfg
Image Version: etch beta 1
Date: 2006/01/24

Machine: sony vaio sr17k
Processor: p3-700
Memory: 128M
Partitions: didn't get that far

Output of lspci and lspci -n:
minitool:/opt# lspci
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP
bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 03)
0000:00:08.0 FireWire (IEEE 1394): Sony Corporation CXD3222 i.LINK
Controller (rev 02)
0000:00:09.0 Multimedia audio controller: Yamaha Corporation YMF-754
[DS-1E Audio Controller]
0000:00:0a.0 Communication controller: Conexant HSF 56k Data/Fax Modem
(Mob WorldW SmartDAA) (rev 01)
0000:00:0c.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 80)
0000:01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV
(rev 11)minitool:/opt# lspci -n
0000:00:00.0 0600: 8086:7190 (rev 03)
0000:00:01.0 0604: 8086:7191 (rev 03)
0000:00:07.0 0601: 8086:7110 (rev 02)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 03)
0000:00:08.0 0c00: 104d:8039 (rev 02)
0000:00:09.0 0401: 1073:0012
0000:00:0a.0 0780: 14f1:2443 (rev 01)
0000:00:0c.0 0607: 1180:0475 (rev 80)
0000:01:00.0 0300: 5333:8c12 (rev 11)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


3 problems that revolve mostly around preseeding.

worst problem is that preseed/early_command is not being run.  I'm
guessing this may be an initrd preseed only issue (pure speculation).  I
googled and saw someone else with a problem, so I will look for a daily
build next, but am submitting this since the issue was not listed on the
etch beta 1 installer errata.  changing to vt2 and doing
debconf-show-selection preseed/early_command shows the right command,
whichif executed in that shell, works.

next problem is that using multiline '\' entries in the preseed file
causes it to be interpreted as bad.  Specifically some 52 line shell
script under lib which I can't remember the name of right now barfs about
shifting.  Easily enough worked around.

Lastly, I have a linksys usb ethernet adapter, and in order to get it to
work I have to do 3 modprobes in preseed/early_command (hence painfulness
above) of crc32, mii, usbnet.

I think the latter two are valid in sarge, which I had working with file
preseeding (no initrd preseeding in sarge).

Finally, I would urge the slightest bit of documentation for what the
implications of the disappearance of base-config/[early/late]_command
disappearing are.  (some comments in the example-preseed.cfg perhaps?)

--- End Message ---
--- Begin Message ---
Source: preseed
Source-Version: 1.17

We believe that the bug you reported is fixed in the latest version of
preseed, which is due to be installed in the Debian FTP archive:

  to pool/main/p/preseed/env-preseed_1.17_all.udeb
  to pool/main/p/preseed/file-preseed_1.17_all.udeb
  to pool/main/p/preseed/initrd-preseed_1.17_all.udeb
  to pool/main/p/preseed/network-preseed_1.17_all.udeb
  to pool/main/p/preseed/preseed-common_1.17_all.udeb
  to pool/main/p/preseed/preseed_1.17.dsc
  to pool/main/p/preseed/preseed_1.17.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 349636@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated preseed package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 19 Jun 2006 18:37:13 -0400
Source: preseed
Binary: env-preseed file-preseed initrd-preseed network-preseed preseed-common
Architecture: source all
Version: 1.17
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 env-preseed - debconf preseeding via environment variables (udeb)
 file-preseed - load debconf preseed file (udeb)
 initrd-preseed - load debconf preseed file from /preseed.cfg on the initrd (udeb)
 network-preseed - download debconf preseed file (udeb)
 preseed-common - common files for preseeding (udeb)
Closes: 251424 349636
 preseed (1.17) unstable; urgency=low
   [ Philip Hands ]
   * add /etc/preseed_aliases file, and code to env2debconf to handle it
     Closes: #251424
   [ Joey Hess ]
   * Removed the DEBCONF_PRIORITY hack. Use debconf/priority= (or now just
     priority=) instead.
   * Support running preseed/early_command in initrd preseeding.
     Closes: #349636
   [ Updated translations ]
   * Spanish (es.po) by Javier Fernández-Sanguino Peña
   * Estonian (et.po) by Siim Põder
   * Polish (pl.po) by Bartosz Fenski
   * Ukrainian (uk.po) by Eugeniy Meshcheryakov
 a00762f542bfd2b59bce89c3f884d25a 639 debian-installer optional preseed_1.17.dsc
 c252615b39b795bd6b033d4d2d2b0994 36364 debian-installer optional preseed_1.17.tar.gz
 5455342ad944772ae1b74ec06c27fc44 13760 debian-installer standard preseed-common_1.17_all.udeb
 8e8e778daecf4ed35105f99c28aa818b 2434 debian-installer standard network-preseed_1.17_all.udeb
 ec9d30e87bb02561aef629be66017f51 2160 debian-installer optional file-preseed_1.17_all.udeb
 43aab77cb442349f46e5b2ed0de95d46 908 debian-installer extra initrd-preseed_1.17_all.udeb
 de5053622621f0bb9ee98b2bf90c388c 1490 debian-installer extra env-preseed_1.17_all.udeb
Package-Type: udeb

Version: GnuPG v1.4.3 (GNU/Linux)


--- End Message ---

Reply to: