[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#367505: Indirect dependency conflict between libgtk+2.0-directfb-dev and libgtk+2.0-directfb0



Package: libgtk+2.0-directfb-dev
Version: 2.0.9.2-13
Severity: important

*** Please type your report below this line ***

The libgtk+2.0-directfb-dev package indirectly conflicts with
libgtk+2.0-directfb0.

The problem is that libgtk+2.0-directfb0 directly depends on
libdirectfb-0.9-22,
while libgtk+2.0-directfb-dev depends on libdirectfb-dev which in turn
depends on libdirectfb-0.9-24.

When compiling the program using  libgtk+2.0-directfb-dev, I get the
following warning:
===========================
gcc    e02.c  -Wall      Pkg-config gtk+-directfb-2.0 --cflags
--libsM/usr/bin/ld: warning: libdirectfb-0.9.so.22, needed by
/usr/lib/directfb/libgtk- directfb.so, may conflict with
libdirectfb-0.9.so.24
/usr/bin/ld: warning: libfusion-0.9.so.22, needed by
/usr/lib/directfb/libgtk-di rectfb.so, may conflict with libfusion-0.9.so.24
/usr/bin/ld: warning: libdirect-0.9.so.22, needed by
/usr/lib/directfb/libgtk-di rectfb.so, may conflict with libdirect-0.9.so.24
===========================



-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15.6
Locale: LANG=pl_PL, LC_CTYPE=pl_PL (charmap=ISO-8859-2)

Versions of packages libgtk+2.0-directfb-dev depends on:
ii  libatk1.0-dev                 1.11.4-2   Development files for the ATK acce
ii  libdirectfb-dev               0.9.24-3   frame buffer graphics library, dev
ii  libgtk+2.0-directfb0          2.0.9.2-13 gtk+2.0 implementation for the fra
ii  libgtk2.0-dev                 2.8.16-1   Development files for the GTK+ lib
ii  libpango1.0-dev               1.12.1-2   Development files for the Pango
ii  pkg-config                    0.20-1     manage compile and link flags for

libgtk+2.0-directfb-dev recommends no packages.

-- debconf-show failed


Reply to: