[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#244975: marked as done (grub-installer fails with simple partition layout)



Your message dated Sun, 14 May 2006 20:57:43 -0300
with message-id <87y7x4i2h4.fsf@nurf.casa>
and subject line Should be fixed in current images of installer
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: 2004-04-19 http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/beta3/sarge-i386-businesscard.iso

uname -a: i wish i could
Date: 2004-04-19
Method: netinstall from "debian.tu-bs.de" i think...

Machine: AMD K6-2, K6BV3+/66 Rev B1

Processor: AMD K6-2 450 MHz
Memory: 512MB
Root Device: IDE (primary master) ST310211A
Root Size/partition table:

         ---Starting---      ----Ending----    Start     Number of
 # Flags Head Sect Cyl   ID  Head Sect Cyl     Sector    Sectors
-- ----- ---- ---- ---- ---- ---- ---- ---- ----------- -----------
 1  0x80    1    1    0 0x83   15   63 1023          63     5468337
 2  0x00   15   63 1023 0x83   15   63 1023     5468400      976752
 3  0x00   15   63 1023 0x83   15   63 1023     6445152    13095936
 4  0x00    0    0    0 0x00    0    0    0           0           0

hda1	/
hda2	swap
hda3	/home

Output of lspci:

00:00.0 Host bridge: VIA Technologies, Inc. VT82C598 [Apollo MVP3] (rev 04)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP] 00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 12) 00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06) 00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 20)
00:12.0 SCSI storage controller: LSI Logic / Symbios Logic 53c810 (rev 23)
00:14.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

the installation of the GRUB bootloader with (hd0,0) failed with error message, but let me reboot the system anyway... on another occasion i tried to install LILO, after GRUB failed, but i did not get any feedback, if the operation was successful...

i tried several different settings for the GRUB settings... (hd0) which was the default, but didn't work either.

my first guess was "cable select" on the HD was not working as supposed, but BIOS recognized the drive right, nevermind where i put it... also exchanged cables and finaly jumperd the drive as master...

/boot/grub/device.map

(fd0)	/dev/fd0
(hd0)	/dev/hda

/boot/grub/menu.lst

title           Debian GNU/Linux, kernel 2.4.25-1-386
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.25-1-386 root=/dev/hda1 ro
initrd          /boot/initrd.img-2.4.25-1-386
savedefault
boot

title           Debian GNU/Linux, kernel 2.4.25-1-386 (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.25-1-386 root=/dev/hda1 ro single
initrd          /boot/initrd.img-2.4.25-1-386
savedefault
boot


any suggestions at what may have gone wrong are more than wellcome...
thanks...


|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

  Dipl. - Des.  Falko Oldenburg
  Entwicklung & Support

  Programmfabrik GmbH
  Frankfurter Allee 73D
  D - 10724 Berlin

  Tel.:  +49 (0)30 - 42081604
  Fax:   +49 (0)30 - 42081606
  Email: falko.oldenburg@programmfabrik.de

  www.programmfabrik.de
  www.easydb.de


--- End Message ---
--- Begin Message ---
Hello,

Looks like your bug is fixed in current installer. Would be good if
you could see if it still reproducable and reopen the bug in case.

Thanks in advance,

p.s.: You can get a new installer image in
http://www.debian.org/devel/debian-installer/

-- 
        O T A V I O    S A L V A D O R
---------------------------------------------
 E-mail: otavio@debian.org      UIN: 5906116
 GNU/Linux User: 239058     GPG ID: 49A5F855
 Home Page: http://www.freedom.ind.br/otavio
---------------------------------------------
"Microsoft gives you Windows ... Linux gives
 you the whole house."

--- End Message ---

Reply to: