[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#255978: marked as done (grub fails: does not have any corresponding BIOS drive)

Your message dated Sun, 14 May 2006 20:57:43 -0300
with message-id <87y7x4i2h4.fsf@nurf.casa>
and subject line Should be fixed in current images of installer
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: Beta 4 110mb image from http://www.debian.org/devel/debian-installer/
uname -a: <The result of running uname -a on a shell prompt>
Date: 2004-06-24 1:48 pm
Method: Boot off CD, network install from mirror.optusnet.com.au, not proxied
boot "linux26" kernel initially, then switched back to default after
display problems

Machine: Compaq Proliant DL380 G3
Processor: Dual 2.8gb Xeon
Memory: 4.5gb
Root Device: 2x72g SCSI, hardware RAID 1 (HP CISS card)
Root Size/partition table:
Disk /dev/cciss/c0d0: 72.8 GB, 72833679360 bytes
255 heads, 32 sectors/track, 17433 cylinders
Units = cylinders of 8160 * 512 = 4177920 bytes

           Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d0p1   *           1        1675     6833984   83  Linux
/dev/cciss/c0d0p2            1676       17433    64292640    f  W95 Ext'd (LBA)
/dev/cciss/c0d0p5            1676       17310    63790784   83  Linux
/dev/cciss/c0d0p6           17311       17433      501824   82  Linux swap

Output of lspci:
0000:00:00.0 Host bridge: ServerWorks CMIC-LE (rev 13)
0000:00:00.1 Host bridge: ServerWorks CMIC-LE
0000:00:00.2 Host bridge: ServerWorks: Unknown device 0000
0000:00:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
0000:00:04.0 System peripheral: Compaq Computer Corporation: Unknown device b203 (rev 01)
0000:00:04.2 System peripheral: Compaq Computer Corporation: Unknown device b204 (rev 01)
0000:00:0f.0 ISA bridge: ServerWorks CSB5 South Bridge (rev 93)
0000:00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 93)
0000:00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 05)
0000:00:0f.3 Host bridge: ServerWorks CSB5 LPC bridge
0000:00:10.0 Host bridge: ServerWorks CIOB-X2 (rev 05)
0000:00:10.2 Host bridge: ServerWorks CIOB-X2 (rev 05)
0000:00:11.0 Host bridge: ServerWorks CIOB-X2 (rev 05)
0000:00:11.2 Host bridge: ServerWorks CIOB-X2 (rev 05)
0000:01:03.0 RAID bus controller: Compaq Computer Corporation Smart Array 5i/532 (rev 01)
0000:02:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5703X Gigabit Ethernet (rev 02)
0000:02:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5703X Gigabit Ethernet (rev 02)
0000:06:1e.0 PCI Hot-plug controller: Compaq Computer Corporation PCI Hotplug Controller (rev 14)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


* Didn't detect ethernet card (should be tg3)
* Can't switch from VT2-5 back to VT1 (get screenful of red vertical lines)
After these first two problems I rebooted to use standard boot image,
instead of linux26.

This time both tg3 interfaces were detected, and switching between VTs
worked fine.

DHCP was fine

I chose to do a automatic partition (separate partitions for home dirs),
and then made all partitions reiserfs instead of ext3.

GRUB installer died with:
Executing 'grub-install (hd0)' failed.
This is a fatal error.

VT3 shows:
Probing devices to guess BIOS drives. This may take a long time.
/dev/cciss/c0d0p1 does not have any corresponding BIOS drive.

/dev/cciss/c0d0p1 is the name of my root partition.

I manually chose to install LILO on /dev/cciss/c0d0 and it worked fine.

On boot there were a pile of errors just after the Partition check:

VFS: Can't find ext3 filesystem on dev cciss0(104,1).
mount: wrong fs type, bad option, bad superblock on /dev2/root2,
	or too many mounted file systems

However the boot was fine.

Defaulting to showing US timezones on base system config annoyed me, as I'm
in Australia. But it didn't cause a problem.

Base config went well. Including aptitude was a nice touch.

After running for a bit, I realised that the base install kernel doesn't
include SMP!  I don't remember seeing an option to use it.

Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---

Looks like your bug is fixed in current installer. Would be good if
you could see if it still reproducable and reopen the bug in case.

Thanks in advance,

p.s.: You can get a new installer image in

        O T A V I O    S A L V A D O R
 E-mail: otavio@debian.org      UIN: 5906116
 GNU/Linux User: 239058     GPG ID: 49A5F855
 Home Page: http://www.freedom.ind.br/otavio
"Microsoft gives you Windows ... Linux gives
 you the whole house."

--- End Message ---

Reply to: