[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#260852: marked as done (grub fails: does not have any corresponding BIOS drive)

Your message dated Sun, 14 May 2006 20:57:43 -0300
with message-id <87y7x4i2h4.fsf@nurf.casa>
and subject line Should be fixed in current images of installer
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: <http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/beta4/sarge-i386-netinst.iso on 07/21/2004>
uname -a: <Linux eumee 2.4.25-1-386 #2 Wed Apr 14 19:38:08 EST 2004 i686 GNU/Linux>
Date: <07/22/2004>
Method: <Boot from cdrom, network install from intranet, no proxy >

Machine: <HP Proliant ML350>
Processor: xeon
Memory: 1G
Root Device: <SCSI /dev/cciss/c0d0>

Root Size/partition table: <
0.3 G on /
6G on /usr
6G on /var
0.3G on /tmp
14G on /home
8G on /someuser
0.5G swap>

Output of lspci:
0000:00:00.0 Host bridge: ServerWorks CNB20-HE Host Bridge (rev 32)
0000:00:00.1 Host bridge: ServerWorks CNB20-HE Host Bridge
0000:00:00.2 Host bridge: ServerWorks CNB20-HE Host Bridge
0000:00:02.0 SCSI storage controller: Adaptec AHA-3960D / AIC-7899A U160/m (rev 01)
0000:00:02.1 SCSI storage controller: Adaptec AHA-3960D / AIC-7899A U160/m (rev 01)
0000:00:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
0000:00:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit Ethernet (rev 02)
0000:00:05.0 System peripheral: Compaq Computer Corporation Advanced System Management Controller
0000:00:0f.0 ISA bridge: ServerWorks CSB5 South Bridge (rev 93)
0000:00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 93)
0000:00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 05)
0000:00:0f.3 Host bridge: ServerWorks CSB5 LPC bridge
0000:00:11.0 Host bridge: ServerWorks CIOB-X2 (rev 05)
0000:00:11.2 Host bridge: ServerWorks CIOB-X2 (rev 05)
0000:02:02.0 RAID bus controller: Compaq Computer Corporation Smart Array 64xx (rev 01)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [?]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

<Great to see that the RAID array and the network controller are recognised, I tried 2 months ago and they did'nt. This solves a big
problem for me. So all went well until GRUB. 
I just had some hesitation during the partitioning concerning the swap,
I expected to find it among the file types, after having redone the
partioning I understood how it works, perhaps I am dumb.
GRUB refused to install,
(... does not have any corresponding bios drive)
I thought the name of the partition is'nt good and I tried others but none worked. I tried also to modify /boot/grub/device.map or delete it
but nothing worked.
I tried then lilo but not much happened (the last message was 
"setting up lilo...."
Then I replay the install from beginning. After GRUB failure, I open
a shell to investigate, I use nano to edit device.map, and then
I try lilo another time, but it refuse to install, complaining that
the lilo package is'nt on the CD (apparently, it has forgotten we are
in a network install).
Then I reinstall from beginning, use directly lilo, and it works!!!>

Claire Boussard.

--- End Message ---
--- Begin Message ---

Looks like your bug is fixed in current installer. Would be good if
you could see if it still reproducable and reopen the bug in case.

Thanks in advance,

p.s.: You can get a new installer image in

        O T A V I O    S A L V A D O R
 E-mail: otavio@debian.org      UIN: 5906116
 GNU/Linux User: 239058     GPG ID: 49A5F855
 Home Page: http://www.freedom.ind.br/otavio
"Microsoft gives you Windows ... Linux gives
 you the whole house."

--- End Message ---

Reply to: