[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#351883: FWD: Re: Bug#351883: further info

----- Forwarded message from József Németh <joe.nemeth@cpluscsystems.axelero.net> -----

From: József Németh <joe.nemeth@cpluscsystems.axelero.net>
Date: Fri, 10 Feb 2006 21:21:16 +0100
To: Joey Hess <joeyh@debian.org>
Subject: Re: Bug#351883: further info
User-Agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)

Thanks for the advice. I have tried, but unfortunately it was out of the
frying-pan and into the fire. The 2.6 kernel in the testing version now freezes
after issueing "Using: /lib/modules/2.6.12-1-386/kernel/drivers/usb/host/
ehci-hcd.ko" twice in succession.

No. Mine is not a weird hw. Slackware 10.1, for instance, runs on it without
any problem. I have even been able to run the ATI installeron my RADEON X600
and set the screen to 1680x1050 resolution. The second failure suggests to me
rather that the debian kernels and/or install scripts are at fault in this

I have also tried the following from DOS

"c:\debian\loadlin.exe c:\debian\vmlinuz root=/dev/ram ro initrd=c:\debian\
initrd.gz ramdisk_size=10000000"

where intrd.gz is copied from the 3.1 r0a CD1 and vmlinuz is from the Slackware
distro. Booting stops after mounting the root. The message

"Mount: Mounting none on /dev failed ...."

was printed and then the kernel panicked. Again I think that the kernel is OK
and something in initrd is not compatible with the situation. (I use loadlin
occasionally to start up my installed Linux system and it works)

Booting from USB stick is not an alternative either. I have tried it. On the
install screen level it not even checked for a CD drive instead searched my HD
and stopped by not finding any boot image there. Looking closer at the kernel
messages,  it timed out on USB access and could not detect the CD format.

One chance is left: changing vmlinuz on the install CD ...

But... could you perhaps help me out with an initrd that enables booting from
the CD set and can be started from dos as above.

Thanks in advance

Joe Németh


Joey Hess wrote:

    József Németh wrote:

        On the problematic machine the HD and its partitions are detected correctly,
        but the log ends with a lot of error messages somethng like:

                                                     devfs_register( ... ): could not
        append to parent - err: -17

    Suggests that for some reason devfs is not properly adding this driver
    to the device tree.

    I'd suggest trying a daily build of the installer, which defaults to a
    newer version of the 2.6 kernel and does not use devfs.


----- End forwarded message -----

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: