[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#342142: Package: installation-reports

On Mon, Dec 05, 2005 at 01:17:44PM -0600, Jones Tones wrote:
> Package: installation-reports
> Boot method: CD
> Image version: http://cdimage.debian.org/cdimage/daily-builds/daily/arch-la<http://cdimage.debian.org/cdimage/daily-builds/daily/arch-la=test/i386/iso-cd/debian-testing-i386-netinst.iso>
> test/i386/iso-cd/debian-testing-i386-netinst.iso<http://cdimage.debian.org/cdimage/daily-builds/daily/arch-la=test/i386/iso-cd/debian-testing-i386-netinst.iso>
> Date: 12/04/05 @ 8:30 PM CST
> Machine: IBM Satellite M65-S8091

Did you mean Toshiba?

IBM doesn't name their machines Satellite and don't have a model like
that.  I am assuming it is a Toshiba.

> Processor: 1.73GHz Intel Pentium M Processor 740 w/Centrino Mobile
> Technology
> Memory: 1G
> Partitions: Didn't get that far.
> Output of lspci and lspci -n: Didn't get that far.
> Base System Installation Checklist:
> [O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it
> Initial boot worked:    [X]
> Configure network HW:   [ ]
> Config network:         [ ]
> Detect CD:              [NO]
> Load installer modules: [ ]
> Detect hard drives:     [ ]
> Partition hard drives:  [ ]
> Create file systems:    [ ]
> Mount partitions:       [ ]
> Install base system:    [ ]
> Install boot loader:    [ ]
> Reboot:                 [ ]
> Comments/Problems: The error that I got was as follows:
> "No common CD-ROM drive was detected.

I suspect it may have an SATA drive, which wasn't supported until very
very recently in 2.6.x kernels.

> You may need to load additional CD-ROM drivers from a driver floppy.
> If you have such a floppy available now, put it in the drive and
> continue. Otherwise, you will be given the option to manually select
> CD-ROM modules."
> <Description of the install, in prose, and any thoughts, comments
>      and ideas you had during the initial install.>
> For what it is worth, Sarge, Fedora 4, Centos 4.2 and
> Ubuntu 5.10 were all able to load my CD-ROM and install. Thanks.

Sarge by default uses a 2.4 kernel which access the ide/sata differently
(not with libata) which tends to work, while 2.6 uses libata and
requires sata atapi support to use the sata cd drives and hence won't
work with 2.6.12 kernel.  I belivee 2.6.14 or 2.6.15 is supposed to have
support for that so hopefully sometime soon debian installers will have
support for it too.  I have had the same problem on a dell laptop where
I could either get cd or hd access with 2.6 under sarge, while 2.4
worked fine, so I installed sarge with 2.4, build a new kernel with
libata patches applied to get sata atapi, and then upgraded to testing
from sarge with apt-get.

Len Sorensen

Reply to: