[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [solved] GTK frontend - Missing symbols from library reduction

Frans Pop wrote:
On Sunday 09 October 2005 03:53, Attilio Fiandrotti wrote:

so , it seems sometimes libc do not contains some needed functions and
you have to explicitly force symbols to be included inside it.

The missing symbols issue is now solved. It turns out that the Makefile for d-i did not include all libraries in the list of files that need to be checked for symbols when calling mklibs.

I have fixed this in my branch for the GTK buildsystem.

The frontend now runs fine with Alastairs udeb, so I have deleted the gtk-directfb tarball. I have also deleted libc from the root tarball.

Please update your build environment to use latest versions for everything.

just done, i was finally able to boot a working miniiso.. horray! whoaa!
some notes:

- in build/pkg-list/gtk-miniiso/common the udeb "libgtk+2.0-directfb0-udeb" appears as "##libgtk+2.0-directfb0-udeb": is this correct? (i've uncommented it on my pc)

- in build/util/get-packages at line 134 i found "$APT_GET -dy --allow-unauthenticated install $needed" and had to change it to " $APT_GET -dy install $needed" because gettin' this error message when making miniiso

E: L'opzione da linea di comando --allow-unauthenticated non è chiara
make[2]: *** [stamps/get_udebs-gtk-miniiso-stamp] Error 100
make[1]: *** [_build] Error 2
make: *** [build_gtk-miniiso] Error 2
(translated: command line option --allow-unauthenticated is not clerly understoodable)

anyway after those two small fixes the gtk build system is ok (except the fonts issue)



Reply to: