[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#301505: installation: PowerPC install failure

Package: installation-reports
Version: 20050320
Severity: normal

Debian-installer-version: Snapshot from 20th March 2005 from http://www.debian.org/devel/debian-installer (netinst.iso)
uname -a: Linux hardknott 2.6.8-powerpc #1 Sun Mar 20 14:09:41 CET 2005 ppc GNU/Linux
Date: 20th March 2005 21:00 GMT
Method: Installation from CDROM booting from CDROM (netinst.iso)

Machine: Apple Mac Mini
Processor: 1.42 GHz PowerPC G4
Memory: 512 MiB
Root Device: /dev/hda3
Root Size/partition table:

        #                    type name                  length   base      ( size )  system
/dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap yaboot                  3907 @ 64        (  1.9M)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 root                 1000001 @ 93815     (488.3M)  Linux native [[MOUNT: /]]
/dev/hda4               Apple_HFS Apple_HFS_Untitled_3  41680816 @ 114620656 ( 19.9G)  HFS
/dev/hda5         Apple_UNIX_SVR2 untitled           113526840 @ 1093816   ( 54.1G)  Linux native [[MOUNT: LVM PV]]
/dev/hda6         Apple_UNIX_SVR2 boot                   89844 @ 3971      ( 43.9M)  Linux native [[MOUNT: UNUSED]]
/dev/hda7              Apple_Free Extra                     16 @ 156301472 (  8.0k)  Free space

Block size=512, Number of Blocks=156301488
DeviceType=0x0, DeviceId=0x0

Output of lspci

0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5962 (rev 01)
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 PCI
0001:10:17.0 ff00: Apple Computer Inc. KeyLargo/Intrepid Mac I/O
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0001:10:1a.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0001:10:1b.0 USB Controller: NEC Corporation USB (rev 43)
0001:10:1b.1 USB Controller: NEC Corporation USB (rev 43)
0001:10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 Internal PCI
0002:20:0d.0 ff00: Apple Computer Inc. UniNorth/Intrepid ATA/100
0002:20:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
0002:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)

and lspci -n:

0000:00:0b.0 0600: 106b:0034
0000:00:10.0 0300: 1002:5962 (rev 01)
0001:10:0b.0 0600: 106b:0035
0001:10:17.0 ff00: 106b:003e
0001:10:18.0 0c03: 106b:003f
0001:10:19.0 0c03: 106b:003f
0001:10:1a.0 0c03: 106b:003f
0001:10:1b.0 0c03: 1033:0035 (rev 43)
0001:10:1b.1 0c03: 1033:0035 (rev 43)
0001:10:1b.2 0c03: 1033:00e0 (rev 04)
0002:20:0b.0 0600: 106b:0036
0002:20:0d.0 ff00: 106b:003b
0002:20:0e.0 0c00: 106b:0031 (rev 81)
0002:20:0f.0 0200: 106b:0032 (rev 80)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [E]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [E]


Creating file systems failed (/dev/hda6, at that time set as /boot
failed).  I went back and set up the partitions again, and this
time it worked.  However, it failed to install the bootloader
on /dev/hda2 (mkofboot failed).  Running it manually also failed.
This is what the installer log shows (transcribed by hand, so there
may be typos):

Setting up yaboot (1.3.13-3)
[does not complete, ps shows this:]
17765 udpkg --configure --force-configure yaboot-installer
17766 /var/lib/dpkg/info/yaboot-installer.postinst
[appeared to wait indefinitely]

yaboot-installer: info: probed /dev/discs/disc0/part4:MacOS X:MacOSX2:macosx
yaboot-installer: debug: mapped: /dev/hda4
yaboot-installer: error: mkofboot failed with exit status 1

# mount
/dev/ide/host0/bus0/target0/lun0/part3 on /target type ext3 (rw)
/dev/ide/host0/bus0/target0/lun0/part6 on /target/boot type ext2 (rw)
/dev/mapper/hda_vg/home on /target/home type ext3 (rw)
/dev/mapper/hda_vg/usr on /target/usr type ext3 (rw)
/dev/mapper/hda_vg/var on /target/var type ext3 (rw)
/dev/cdroms/cdrom0 on /target/media/cdrom0

# chroot /target
# mkofboot
mkofboot: Create hfs filesystem on /dev/hda2? [y/N] y
hformat: /dev/hda2 volume is smaller than 800K (Invalid argument)
mkofboot: HFS filesystem creation failed!

==> /dev/hda1 is 1.9 MiB, so I concluded that the partition table
used by the kernel was wrong.  I tried partitioning with the
installer two more times, but couldn't get it to with the installer
or manually as above.

I couldn't resolve this, so I rebooted.  I had to boot the new system by
hand using a root= parameter with the yaboot on the installation CD.
The reason for the failure became apparent: /dev/hda6 was not mountable
and was probably corrupt (/boot).  There was no detectable filesystem on
there.  I think this was a failure to reload the partition table after
finishing partitioning, which also cause the filesystem
creation error.

The following day I started over from scratch.   I left the partitioning
the same, but reformatted them all.  Before configuring LVM, all
hda filesystems were created OK, and all LVM filesystems created OK too.
The installation then proceeded and completed without any problems.
yaboot installed OK, and rebooting completed OK too.


-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (990, 'unstable')
Architecture: powerpc (ppc)
Kernel: Linux 2.6.8-powerpc
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Reply to: