[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#298595: it's a BIOS problem

Since the original report on this bug thread, I had one more access to the
machine and tried it again. This time I had my USB stick prepared using
"the flexible way" as per the helpful doc at http://d-i.pascal.at/ ;
the partition was made pure FAT16 this time, and only mounted with
	mount -t msdos

I had also verified that the MBR is loaded from the stick OK -- by holding
the CTRL key, I get the 1FA: prompt, pressing "F" correctly spins up the
floppy etc. However, it then goes on to "Boot failed" if I try to continue
booting. It is the fact that the MBR goes up OK that lead me initially to
suspect the remainder of what's on the stick (I figured -- once smth off
the USB stick has gotten control, it should go on by itself then).

BTW, the stick (M-Systems 256m) has 2 lights - orange for USB2 high-speed
access and green for low-speed USB1.1 mode. It stayed green throughout.

It seems to me that the default drive
(install-mbr -d 0x80 <the usb device>)
is not correctly re-mapped to become the 1st hard drive through the boot
sequence on this machine. I had tried -d 0x81 -d 0x82 and -d 0, all in

However, the default setting (-d 0x80) turned out to work OK on another
machine, with a different motherboard/BIOS, with the very same USB stick.

I see 2 options: 1) try upgrading the BIOS to the latest on the
problematic machine (I have gotten permission from the University
sysadmins to try to do it) 2) try a partitionless stick - maybe that one
will be working, treated by the BIOS same way as a floppy works
- but this would prevent me from carrying my needed stuff in my 2nd
  partition (ext2) of the same stick...

I'll report on this thread about the specific BIOS versions and the
motherboard specs later on.

Reply to: