[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#298465: RAID/LVM Partition Table Bug

Package: installation-reports

Debian-installer-version: March 7, 2005 http://people.debian.org/~joeyh/d-i/images/daily/floppy/
uname -a: Linux temp 2.4.27-2-686 #1 Thu Jan 20 11:10:41 JST 2005 i686 GNU/Linux
Date: March 7, 2005 11am
Method: Net Install of Sarge using Floppies - http://http.us.debian.org/

      Machine: Dell PowerEdge 2450
      Processor: 2 x PIII 866
      Memory: 2GB PC133 ECC Registered
      Root Device: SCSI /dev/sd0
      Root Size/partition table: 2GB
	    Output of lspci and lspci -n:

	    Base System Installation Checklist:
	    [O] = OK, [E] = Error (please elaborate below), [ ] = didn't
	    try it

	    Initial boot worked:    [O]
	    Configure network HW:   [O]
	    Config network:         [O]
	    Detect CD:              [O]
	    Load installer modules: [O]
	    Detect hard drives:     [O]
	    Partition hard drives:  [E]
	    Create file systems:    [O]
	    Mount partitions:       [O]
	    Install base system:    [O]
	    Install boot loader:    [O]
	    Reboot:                 [O]


	    Everything worked great.  Minor problem during Partitioning:

	    When manually editing the partition table, after setting up
	    Software RAID or LVM, the RAID metadisks and LVM logical
	    volumes show up in the list as devices with a single partition
	    listed under each of them.  If you only mess with the single
	    partition listed under each device, everything works fine.
	    However, if you select a RAID or LVM device itself, it asks
	    you if you want to create a new partition table on that
	    device.  If you do, it allows you to further partition a
	    RAID or LVM device.  Of course, Software RAID and LVM don't
	    support partitioning a metadisk or logical volume, so doing
	    this would probably confuse the installer and make a mess.

Reply to: