[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#297740: base-installer: sparc32 kernels not usable for sparc64



On Wed, Mar 02, 2005 at 05:03:59PM -0800, Blars Blarson wrote:
> In article <E1D6Wnn-0003e4-00@master.debian.org> aragorn@tiscali.nl writes:
> >According to Jurij Smakov, sparc32 kernels are not usable on a sparc64.
> 
> >I think one reason is that sparc32 kernels are configured without PCI
> >support and sparc64 machines need that.
> 
> That's a tiny portion of the reason on some ultrasparc systems.  (Some
> ultrasparc systems are sbus not pci.)  Lack of support for the kernel
> registers, mmu, and so forth has a lot more to do with it.
> 
> I don't see the point of this bug report.  Is something trying to
> install a 32-bit kernel on a 64-bit system, or are you just wanting to
> be able to do something that will never work?

Frans filed this report on my request, because base-installer needs to
be taught that sparc32 kernels are not usable on sparc64.

Cheers,

-- 
Colin Watson                                       [cjwatson@debian.org]



Reply to: