[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#297761: Package: installation-reports

Package: installation-reports

downloaded 28/02/05
uname -a: n/a
Date: 02/03/05 18:00 MET
Method: install via serial console
Machine: Intel SR1325 Server,
Processor: 3.0Ghz Pentium HT
Memory: 512MB
Root Device: /dev/md0, IDE
Root Size/partition table:
/dev/hda 160GB
physical part 0 512MB swap
physical part 1 50MB
physical part 2 100GB
physical part 3	49,5GB

/dev/hdb 160GB
physical part 0 512MB swap
physical part 1 50MB
physical part 2 100GB
physical part 3	49,5GB

created /dev/md0 with /dev/hda1 and /dev/hdb1 as /boot with ext2fs
created /dev/md1 with /dev/hda2 and /dev/hdb2 as / with ext3fs
created /dev/md2 with /dev/hda3 and /dev/hdb3 as /var with ext3fs

Output of lspci and lspci -n: n/a

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


Rebooted system after successful install, following error appeared on


Booting 'Debian GNU/Linux, kernel 2.4.27-1-386 '

root  (hd0,0)
 Filesystem type unknown, partition type 0x82
kernel  /vmlinuz-2.4.27-1-386 root=/dev/md1 ro console=ttyS0

Error 17: Cannot mount selected partition


it seems as if the installer has created a wrong configuration file for
grub with the wrong location of vmlinuz-... vmlinuz is on hd0,1 not on
what i tried to solve the problem:
after the error was displayed during boot, i changed to grub command line
and issued:  "kernel (hd0,1)/vmlinuz-2.4.27-1-386 root=/dev/md1" and
this makes grub find the kernel and boot it but the kernel then panics
with "VFS cannot open root device "md1" or 09:01" and "Please append a
correct "root=" boot option

so, is this a bug or a feature ;)???

this link has proven to be useful:


Reply to: