[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#292943: Sarge Installer Bug Report

Package: installation-reports

Debian-installer-version: 27-Jan-2005, http://ftp.acc.umu.se/pub/cd-images/debian-weekly/i386/sarge-i386-1.iso
Weekly CD set:  24-Jan-2005 17:23

uname -a: inux vectra 2.6.8-2-686 #1 Sat Jan 8 16:50:08 EST 2005 i686 GNU/Linux
Date: Jan 27 21:46
Method:  - installation CD's burned from the ISO's.

Machine: HP Vectra VL8i
Processor: Pentium III (Katmai)/550 MHz with 512K of L2 cache
Memory: 256M
Root Device: IDE, (hd0,2)
Root Size/partition table:

sfdisk -l /dev/hda

Disk /dev/hda: 77545 cylinders, 16 heads, 63 sectors/track
Warning: The partition table looks like it was made
  for C/H/S=*/240/63 (instead of 77545/16/63).
For this listing I'll assume that geometry.
Units = cylinders of 7741440 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1   *      0+   1023    1024-   7741408+   b  W95 FAT32
/dev/hda2       5030    5168     139    1050840   82  Linux swap
/dev/hda3       1024    2410    1387   10485720   83  Linux
/dev/hda4       2411    5029    2619   19799640    f  W95 Ext'd (LBA)
/dev/hda5       2411+   5029    2619-  19799608+   b  W95 FAT32

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03) 0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:04.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:04.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:04.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:06.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01) 0000:00:0b.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30) 0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 03)

0000:00:00.0 0600: 8086:7190 (rev 03)
0000:00:01.0 0604: 8086:7191 (rev 03)
0000:00:04.0 0601: 8086:7110 (rev 02)
0000:00:04.1 0101: 8086:7111 (rev 01)
0000:00:04.2 0c03: 8086:7112 (rev 01)
0000:00:04.3 0680: 8086:7113 (rev 02)
0000:00:06.0 0401: 1013:6003 (rev 01)
0000:00:0b.0 0200: 10b7:9055 (rev 30)
0000:01:00.0 0300: 102b:0521 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:		[O]
Configure network HW:	[ ]
Config network: 		[O]
Detect CD: 			[O]
Load installer modules:	[O]
Detect hard drives:		[O]
Partition hard drives:	[O]
Create file systems:		[O]
Mount partitions:		[O]
Install base system:		[E]
Install boot loader:		[O]
Reboot:				[E]


First I booted the installation with "linux26".

During the "Install base system" process the 2.6 kernel compiled for K7 CPU's was installed, instead of i686 version suitable for this system!

After reboot my box was frozen directly after kernel decompression!

Then I run the installation again (with 2.4 kernel), and after the whole intallation process (and final reboot), I used the aptitude tool to install proper i686 2.6 kernel for i686 CPU's, and removed the 2.4 one (with purge option).

On HP Vectra VL8i an acpi=force option is required to run things properly under Linux too (acpi code "thinks" that BIOS is too old - but this is normal :-)).
Here's the dmesg output (hope it will also help):

=== (kernel booted with: acpi=force) ===
Linux version 2.6.8-2-686 (dilinger@toaster.hq.voxel.net) (gcc version 3.3.5 (Debian 1:3.3.5-5)) #1 Sat Jan 8 16:50:08 EST 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
 BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000ea800 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
 BIOS-e820: 000000000fff0000 - 000000000ffffc00 (ACPI data)
 BIOS-e820: 000000000ffffc00 - 0000000010000000 (ACPI NVS)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
255MB LOWMEM available.
On node 0 totalpages: 65520
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 61424 pages, LIFO batch:14
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.2 present.
ACPI: RSDP (v000 PTLTD ) @ 0x000f6f10 ACPI: RSDT (v001 PTLTD RSDT 0x00000001 LTP 0x00000000) @ 0x0fffb822 ACPI: FADT (v001 HP HolmesHZ 0x00000001 PTL 0x00000001) @ 0x0fffb84e ACPI: BOOT (v001 PTLTD $SBFTBL$ 0x00000001 LTP 0x00000001) @ 0x0ffffbd9 ACPI: DSDT (v001 HP HolmesHZ 0x00000001 MSFT 0x01000007) @ 0x00000000
ACPI: PM-Timer IO Port: 0x8008
Built 1 zonelists
Kernel command line: root=/dev/hda3 ro acpi=force
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
PID hash table entries: 1024 (order 10: 8192 bytes)
Detected 551.323 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 251652k/262080k available (1545k kernel code, 9708k reserved, 684k data, 148k init, 0k highmem) Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 1093.63 BogoMIPS
Security Scaffold v1.0.0 initialized
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 0383fbff 00000000 00000000 00000000
CPU: After vendor identify, caps:  0383fbff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After all inits, caps:        0383fbff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel Pentium III (Katmai) stepping 03
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 551.0155 MHz.
..... host bus clock speed is 100.0209 MHz.
checking if image is initramfs...it isn't (ungzip failed); looks like an initrd
Freeing initrd memory: 4624k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfd9a3, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: IRQ9 SCI: Level Trigger.
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled. ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled. ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 6 7 9 10 11 14 15) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
PnPBIOS: Scanning system for PnP BIOS support...
PnPBIOS: Found PnP BIOS installation structure at 0xc00f7000
PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0x891c, dseg 0x400
pnp: 00:0a: ioport range 0x4d0-0x4d1 has been reserved
pnp: 00:0a: ioport range 0x8000-0x803f has been reserved
pnp: 00:0a: ioport range 0x1040-0x104f has been reserved
PnPBIOS: 17 nodes reported by PnP BIOS; 17 recorded by driver
PCI: Using ACPI for IRQ routing
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:04.2[D] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 10
ACPI: PCI interrupt 0000:00:06.0[A] -> GSI 10 (level, low) -> IRQ 10
ACPI: PCI interrupt 0000:00:0b.0[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 9
ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 9 (level, low) -> IRQ 9
Simple Boot Flag value 0x0 read from CMOS RAM was invalid
Simple Boot Flag at 0x3b set to 0x1
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
NET: Registered protocol family 8
NET: Registered protocol family 20
ACPI: (supports S0 S1 S4 S5)
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4624 blocks [1 disk] into ram disk... done.
VFS: Mounted root (cramfs filesystem) readonly.
Freeing unused kernel memory: 148k freed
vesafb: probe of vesafb0 failed with error -6
NET: Registered protocol family 1
SCSI subsystem initialized
libata version 1.02 loaded.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 0000:00:04.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdc:DMA, hdd:pio
hda: ST340015A, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 128KiB
hda: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(33)
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4 < p5 >
hdc: CD-224E, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
[2342] init_ext3_fs(), err = 0
VFS: Can't find ext3 filesystem on dev hda3.
VFS: Can't find ext2 filesystem on dev hda3.
ReiserFS: hda3: found reiserfs format "3.6" with standard journal
ReiserFS: hda3: using ordered data mode
ReiserFS: hda3: journal params: device hda3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda3: checking transaction log (hda3)
ReiserFS: hda3: Using r5 hash to sort names
Adding 1050832k swap on /dev/hda2.  Priority:-1 extents:1
Real Time Clock Driver v1.12
hdc: ATAPI 24X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
Capability LSM initialized
Linux agpgart interface v0.100 (c) Dave Jones
PCI: Enabling device 0000:00:0b.0 (0110 -> 0113)
ACPI: PCI interrupt 0000:00:0b.0[A] -> GSI 11 (level, low) -> IRQ 11
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
0000:00:0b.0: 3Com PCI 3c905B Cyclone 100baseTx at 0x1080. Vers LK1.1.19
PCI: Enabling device 0000:00:06.0 (0100 -> 0102)
ACPI: PCI interrupt 0000:00:06.0[A] -> GSI 10 (level, low) -> IRQ 10
Crystal 4280/46xx + AC97 Audio, version 1.28.32, 17:36:04 Jan  8 2005
cs46xx: Card found at 0xf4100000 and 0xf4000000, IRQ 10
cs46xx: Unknown card (1013:4280) at 0xf4100000/0xf4000000, IRQ 10
ac97_codec: AC97 Audio codec, id: CRY3 (Cirrus Logic CS4297)
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
PCI: Enabling device 0000:00:04.2 (0000 -> 0001)
ACPI: PCI interrupt 0000:00:04.2[D] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:04.2: Intel Corp. 82371AB/EB/MB PIIX4 USB
uhci_hcd 0000:00:04.2: irq 11, io base 00001020
uhci_hcd 0000:00:04.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usb 1-1: new low speed USB device using address 2
usbcore: registered new driver hiddev
input: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:04.2-1
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
ts: Compaq touchscreen protocol output
mice: PS/2 mouse device common for all mice
input: PC Speaker
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 1 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
inserting floppy driver for 2.6.8-2-686
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
agpgart: Detected an Intel 440BX Chipset.
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: AGP aperture is 64M @ 0xf8000000
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
pciehp: PCI Express Hot Plug Controller Driver version: 0.4
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02fd020(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present

-Krzysztof "Chris" Mlynarski

Attachment: smime.p7s
Description: S/MIME cryptographic signature

Reply to: