[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#292747: Sarge weekly CD (i-d rc2) fails to reboot on hde3

Package: installation-reports

Debian-installer-version:   Sarge weekly cd from:

     on 29 January 2005
          The real live Sarge CD linked from the Debian home page.  The one
	  we're trying to make solid enough to cut a real release of.

uname -a:  System doesn't boot.
Date: 29 Jan 2005, 3:30AM Pacific time
Method: Burned a Sarge install CD 1 and booted from it.

Machine: Dual Athlon 1800+ PC.  Two extra PCI Promise Ultra133-TX2 IDE
     No hard drives are on the motherboard IDE controller (only the cheap
     generic DVDROM, on hda).
     (This ASUS motherboard has a bug in the IDE controller that gives it
     higher bus priority than the PCI bus, and in some applications we drive
     the PCI bus at >40 Mbytes/sec.  So all disks are on PCI slots.)
     Drives on hde, hdf, hdg.  Root on hde3.  (hde1&2 are a Knoppix install
     that I didn't clobber.)
     This system has run Mandrake for several years, ran KNOPPIX for a year,
     ran KNOPPIX 3.7 this week.
Processor:  Dual AthlonMP 1800+.
Memory:  512MB
Root Device: IDE, Western Digital 200GB drive.
Root Size/partition table: hde1 1GB Knoppix /boot
			   hde2 100GB Knoppix root
			   hde3 90GB  Sarge root (installed by d-i)
			   hde5 small Sarge swap (installed by d-i)
Output of lspci and lspci -n:
       (don't have system running -- do you need it?)       

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [???]  it didn't mount any of my other partitions.
			       (That's a good thing.)  Mounted its own hde3
			       without any trouble.
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


	It all appeared fine until the reboot.  On reboot, it doesn't seem to
	load the ide-detect module, so it doesn't detect ide2 at all.
	But that's where the root partition is, so it fails in pivot_root.
	(That's my guess at what's going wrong.)

        Last console messages are:

	  ide: Asuming 33 MHz ...
	  ide: late registration of driver
	  hda: LITE-ON COMBO ... CD/DVD...
	  ide0 at 0x1f0-0x1f7, ...
	  Journaled Block Device driver loaded
	  pivot_root: No such file or directory
	  /sbin/init: 431: cannot open dev/console: No such file
	  kernel panic: Attempted to kill init

	I tried a variety of kernel boot parameters to see if I could
	get it to recognize ide2 and hde.  "ide-detect" did nothing.
	"ide2=0xb400" did see the card and the drives, but got lots of
	errors due to (I guess) the control port being wrong.
	"ide2=0xb400,0xb002" doesn't even see the drive.  This, however,
	is what the kernel PRINTS for this card when booting from the CDROM
	and doing hardware detection.  "ide2=0xb400,0xb002,16" also doesn't
	see the drive or change the erroneous output above.  (The CDROM
	prints that the IRQ is 16.)

Reply to: