[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

hppa 2.6 badness

Bdale, I found out today that the d-i hppa netboot images for 2.6 have
been broken for a while. I thought they were working because my daily
test setup was falling back to using a boot image that I built by hand,
probably months ago, because I had a wrong path set. When I fixed it to
use the current images, I got this:

attempt to access beyond end of device
ram0: rw=0, want=18146, limit=16384
attempt to access beyond end of device
ram0: rw=0, want=18904, limit=16384

I guess the ramdisk is the wrong size. I'm suprised this didn't come up in 
your recent testing though -- could it somehow only affect my a500? I tried
passing a ramdisk_size=20000 to the kernel and that works around it. However
I then don't have enough command-line space to do preseeding.

Now it seems to me that the boot.img is 13 mb only because 9.5 mb are
used by the kernels. The initrd is only 3.4 mb, and though it
uncompresses to a 12 mb image, that doesn't explain how we're filling up
a 16 mb ramdisk. Is palo doing something stupid, such as loading the
kernels into memory along with the initrd as the ramdisk?

Anyway, I notice there's a fair bit of cruft on the hppa initrds and
perhaps we should apply this patch:

--- pkg-lists/netboot/hppa.cfg  (revision 25106)
+++ pkg-lists/netboot/hppa.cfg  (working copy)
@@ -1,10 +1,5 @@
 nic-modules-${kernel:Version} *

That stuff used to be included from the kernel_specific file for hppa 2.6,
but that file is gone now that 2.4 is gone, and we could trim this down
now. I don't know if it would get the ramdisk under the 16 mb it seems to
need to be. My a500 is insufficiently stable to do d-i development on.

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: