[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#290994: [powerpc] [20050114] installation of d-i snapshot on Mac G4 Cube

Package: installation-reports

Debian-installer-version: 20050114 from
uname -a: Linux Carrera 2.6.8-powerpc #1 Sat Jan 8 22:01:09 CET 2005 ppc
Date: 2005-01-17
Method: sarge-powerpc-netinst.iso burned onto CD-RW
Machine: Apple Macintosh G4 Cube
Processor: G4, 450 MHz PowerMac5,1 (from /proc/cpuinfo: "detected as: 68
(PowerMac G4 Cube)")
Memory: 512 MB (2x 256 MB)
Root Device: /dev/hda12 (internal IDE hard drive)
Root Size/partition table:
:~$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda12             2533100   1751896    781204  70% /
tmpfs                   257684         0    257684   0% /dev/shm
/dev/hda14             6130880     36068   6094812   1% /home
/dev                   2533100   1751896    781204  70% /.dev
none                      5120       576      4544  12% /dev

Output of lspci and lspci -n:

$ lspci
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage 128
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth PCI
0001:10:17.0 ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 03)
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:1a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394
Controller (Link)
0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth Internal PCI
0002:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth GMAC (Sun
GEM) (rev 01)

$ lspci -n
0000:00:0b.0 0600: 106b:0020
0000:00:10.0 0300: 1002:5046
0001:10:0b.0 0600: 106b:001f
0001:10:17.0 ff00: 106b:0022 (rev 03)
0001:10:18.0 0c03: 106b:0019
0001:10:19.0 0c03: 106b:0019
0001:10:1a.0 0c00: 104c:8020
0002:20:0b.0 0600: 106b:001e
0002:20:0f.0 0200: 106b:0021 (rev 01)

Output of lsusb and lsusb -t:

$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 05ac:0302 Apple Computer, Inc. Apple Optical Mouse
Bus 001 Device 005: ID 05ac:0204 Apple Computer, Inc.
Bus 001 Device 004: ID 05ac:9213 Apple Computer, Inc.
Bus 001 Device 003: ID 05ac:1002 Apple Computer, Inc. Apple Extended
Keyboard Hub [Mitsumi]
Bus 001 Device 002: ID 04cc:1122 Philips Semiconductors Hub
Bus 001 Device 001: ID 0000:0000

$ lsusb -t
Bus#  2
`-Dev#   1 Vendor 0x0000 Product 0x0000
Bus#  1
`-Dev#   1 Vendor 0x0000 Product 0x0000
  `-Dev#   2 Vendor 0x04cc Product 0x1122
    |-Dev#   3 Vendor 0x05ac Product 0x1002
    | |-Dev#   5 Vendor 0x05ac Product 0x0204
    | `-Dev#   6 Vendor 0x05ac Product 0x0302
    `-Dev#   4 Vendor 0x05ac Product 0x9213

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


* I had to use video=ofonly to get yaboot to work (black screen at boot).
The font is fairly hard to read (especially compared to the Linux fbdev
font), which also caused some problems. Is there any way to build a list
of machine types into yaboot to tell it to use 'video=ofonly'? (No
problems once I figured that part out.)

* The internal hard drive was detected, but I had to manually load
ohci1394, sbp2 and sd_mod to see the external FireWire drive.

* I still can't figure out how to get X to work. Below are some lines from
XFree86.0.log relating to the framebuffer:

(II) FBDEV(0): using default device
(II) Running in FRAMEBUFFER Mode
(**) FBDEV(0): Depth 24, (--) framebuffer bpp 32
(==) FBDEV(0): RGB weight 888
(==) FBDEV(0): Default visual is TrueColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: OFfb ATY,Rage12 (video memory: 768kB)
(II) FBDEV(0): checking modes against framebuffer device...
(II) FBDEV(0):  mode "1152x864" ok
(II) FBDEV(0):  mode "1024x768" ok
(II) FBDEV(0):  mode "800x600" ok
(II) FBDEV(0):  mode "640x480" ok
(II) FBDEV(0): checking modes against monitor...
(**) FBDEV(0): using shadow framebuffer
(--) Depth 24 pixmap format is 32 bpp
(EE) FBDEV(0): FBIOPAN_DISPLAY: Invalid argument
(==) FBDEV(0): Backing store disabled
(**) FBDEV(0): DPMS enabled

I will check some of the other X server options out later. This was with
4.3.0.dfsg.1-10. I also tried rebooting into OS X to try initial modes of
1152x864 and 1024x768, but both caused the above error.

Charles Lepple

Reply to: