[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Create software raid array during install, error when filesystems is created.

On Thu, Jan 06, 2005 at 10:07:48PM +0100, Bj?rn Nilsson wrote:
> Hi,
> I have 2 equally sized IDE PATA disks.
> I created a partition covering the whole drive on each disk, the
> partition type was "raid".
> I created a software RAID0 array, and in turn created partitions on it
> and set them to ReiserFS.

So you created one big RAID partition, and then made partitions in it? This
is contrary to the way RAID on Linux works, and if partman allowed you to do
it, that's a bug, and explains what happened next...
> In the next step, When the filesystem are supposed to be created a get
> a red screen telling me: " Failed to create ReiserFS part1 on RAID0-
> unit0". If i swich to the third virtual console i see this messsage:
> "Stat of the device /dev/md/0/part1" failed.
> I have tried RAID1 also, ext3 instead of Reiser. Also tried to use the
> LVM to set up a volume group and so on, all with about the same
> result, failure when creating file system.
> So I installed on just 1 drive as normal, and that worked fine
> (impressive stuff with the hw autodetection btw!)
> I have tried with rc2 and nightly build from 2005-01-05, same result
> I read some problems with lilo or grub when using software raid, but
> that seems unrelated becouse this is well before any bootloader is
> installed.

If you want to do what you've described, you'll need to put LVM over the top
of the RAID0 volume, and create multiple logical volumes out of it, and
treat them as you would partitions.



linux.conf.au 2005   -  http://linux.conf.au/  -  Birthplace of Tux
April 18th to 23rd   -  http://linux.conf.au/  -       LINUX
Canberra, Australia  -  http://linux.conf.au/  -    Get bitten!

Attachment: signature.asc
Description: Digital signature

Reply to: