[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#287125: install report


http://www.nl.debian.org/devel/debian-installer/ 12-20-2004 8:49AM -5:00

uname -a: Linux Mommz 2.6.8-1-386 #1 Thu Nov 11 12:18:43 EST 2004 i686
Date: 12-24-2004 12:10AM -5:00

Method: How did you install?  What did you boot off?  If network
     install, from where?  Proxied?
NetInst, booted from IDE CDRW. I use linux26 as the 2.4 kernel hangs as
it starts the disk partitioning tool. I used the mirror at
ftp.egr.msu.edu for my apt source. However, I have tried 4 or 5 other
mirrors with identical results.

Machine: Custom. Gigabyte K8NPro, NForce3 chipset with onboard Realtek
gigabit ethernet. Eth1 ADMtek wireless NIC not utilized, although I will
be attempting that soon.

Processor: AMD64

Memory: 512meg DDR PC3200

Root Device: ATA133 Maxtor 160 gig

Root Size/partition table:
hda is one Windows partition
Disk /dev/hdb: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1        3824    30716248+  a5  FreeBSD
/dev/hdb2            3825        7648    30716280   83  Linux-saved for
Libranet beta
/dev/hdb3            7649        7779     1052257+  82  Linux swap
/dev/hdb4            7780       19929    97594875    5  Extended
/dev/hdb5            7780       10329    20482843+  83  Linux-saved for
Libranet beta
/dev/hdb6           10330       13855    28322563+  83  Kanotix (2.6.9)
/dev/hdb7           14895       19929    40443606   83  Linux -/home
/dev/hdb8   *       13856       14894     8345736   83  Linux -/

Partition table entries are not in disk order

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: nVidia Corporation nForce3 Host Bridge (rev a4)
0000:00:01.0 ISA bridge: nVidia Corporation nForce3 LPC Bridge (rev a6)
0000:00:01.1 SMBus: nVidia Corporation nForce3 SMBus (rev a4)
0000:00:02.0 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5)
0000:00:02.1 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5)
0000:00:02.2 USB Controller: nVidia Corporation nForce3 USB 2.0 (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce3
Audio (rev a2)
0000:00:08.0 IDE interface: nVidia Corporation nForce3 IDE (rev a5)
0000:00:0a.0 PCI bridge: nVidia Corporation nForce3 PCI Bridge (rev a2)
0000:00:0b.0 PCI bridge: nVidia Corporation nForce3 AGP Bridge (rev a4)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:07.0 Network controller: Linksys ADMtek ADM8211 802.11b Wireless
Interface (rev 11)
0000:01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8169 Gigabit Ethernet (rev 10)
0000:01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23
IEEE-1394a-2000 Controller (PHY/Link)
0000:02:00.0 VGA compatible controller: nVidia Corporation NV18
[GeForce4 MX 4000 AGP 8x] (rev a4)

0000:00:00.0 0600: 10de:00d1 (rev a4)
0000:00:01.0 0601: 10de:00d0 (rev a6)
0000:00:01.1 0c05: 10de:00d4 (rev a4)
0000:00:02.0 0c03: 10de:00d7 (rev a5)
0000:00:02.1 0c03: 10de:00d7 (rev a5)
0000:00:02.2 0c03: 10de:00d8 (rev a2)
0000:00:06.0 0401: 10de:00da (rev a2)
0000:00:08.0 0101: 10de:00d5 (rev a5)
0000:00:0a.0 0604: 10de:00dd (rev a2)
0000:00:0b.0 0604: 10de:00d2 (rev a4)
0000:00:18.0 0600: 1022:1100
0000:00:18.1 0600: 1022:1101
0000:00:18.2 0600: 1022:1102
0000:00:18.3 0600: 1022:1103
0000:01:07.0 0280: 1317:8201 (rev 11)
0000:01:0b.0 0200: 10ec:8169 (rev 10)
0000:01:0e.0 0c00: 104c:8024
0000:02:00.0 0300: 10de:0185 (rev a4)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [ ]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


There is no installation problem if I use the entire 15 cds of Debian
testing. The problem is with network connectivity. After a variable
period of 30 seconds to 3 minutes I lose network connectivity. The
correct module is installed and all the config files are correct.
Nothing other than a reboot will restore connectivity, not removing and
reinstalling the r8169 module, not /etc/init.d/networking force-reload,
not ifconfig eth0 down and up. Ifconfig at the time it has stopped working:

eth0      Link encap:Ethernet  HWaddr 00:0D:61:6D:A3:8F
         inet addr:  Bcast:  Mask:
         RX packets:3410 errors:0 dropped:0 overruns:0 frame:0
         TX packets:1853 errors:0 dropped:64 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:4964313 (4.7 MiB)  TX bytes:125033 (122.1 KiB)
         Interrupt:201 Base address:0x7000

lo        Link encap:Local Loopback
         inet addr:  Mask:
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:173 errors:0 dropped:0 overruns:0 frame:0
         TX packets:173 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:15044 (14.6 KiB)  TX bytes:15044 (14.6 KiB)

and a ping to my router:

PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable

--- ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 2998ms
, pipe 3

If I try to reconfigure with dhclient eth0:

eth1 unknown hardware address type 24
eth1 unknown hardware address type 24
Listening on LPF/eth0/xx:xx:xx:xx:xx:xx (correct MAC address for eth0)
Sending on   LPF/eth0/xx:xx:xx:xx:xx:xx
Sending on   Socket/fallback/fallback.net
DHCPDISCOVER on eth0 to port 67 interval 4
DHCPDISCOVER on eth0 to port 67 interval 7
DHCPDISCOVER on eth0 to port 67 interval 10
DHCPDISCOVER on eth0 to port 67 interval 17
DHCPDISCOVER on eth0 to port 67 interval 19
DHCPDISCOVER on eth0 to port 67 interval 3
No DHCPOFFERs received
No working leases in persistent database.


If I remove the router and connect directly to my cablemodem I am unable
to get any connection, even immediately after boot. No DHCPOFFER is ever
detected. Works fine directly connected to the same computer booted from
Windows. If I use static IPs rather than DHCP I experience the exact
same problem.

If I use Kanotix Bug Hunter 9a, a custom kernel based on the 2.6.8-10
kernel, but not the Debian kernel, I have no connectivity problems.

I experience the same problem when installing the AMD64 port.

Obviously, I end with a functioning base system. It merely lacks access
to my LAN and the Internet. I am not a stoopid noob. I have used a
Debian-based distro for 5 years now, and Linux even before that. My
/etc/network/interfaces file is correct. So is my /etc/resolv.conf, and
my /etc/host.

How can I help fix this? What other info might be needed?


Reply to: