[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#287030: [powerpc][rc2] Fails to boot newer Apple G5 PowerMac

Package: installation-reports
Severity: important

Debian-installer-version: RC2 Netinst, also 20041219 Business Card ISO
uname -a: <did not boot>
Date: Dec 20, 2004
Method: Tried CD and hard disk boot

Machine: Apple Dual 2.0 Ghz G5 Power Mac
Processor: Dual PowerPC G5 2.0 Ghz
Memory: 512 MB
Root Device: <SATA 160G Hard Drive was intended target>
Root Size/partition table: <did not get this far>
Output of lspci and lspci -n: <cannot get this far>

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


This system will not boot off the Sarge kernels. Earlier versions of
this hardware apparently did boot correctly


On booting this bit of hardware with the power4 kernel I see

... ok
opening display /pci@0,f0000000/NVDA,Parent@10/NVDA,Display-A@0...ok
copying OF device tree...done
starting cpu /cpus/PowerPC,G5...failed: 00000000
Initializing fake screen: NVDA,Display-B
Calling quiesce...
returning 0x014000000 from prom_init

and then a white screen. Using 'video=ofonly' does not help. My
OpenFirmware version is

Apple PowerMac7, BootROM built on 09/29/04 at 18:56:06
Copyright 1994-2004 Apple Computer, Inc.
All Rights Reserved

As you can see, it was built less than a month ago.

I reported #286761 against kernel-image-2.6.8-power4-di initially, it
is really a duplicate of this report.

Please contact me for details or assistance with furthur testing.

Best regards,

Reply to: