[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283754: marked as done (hppa install on a500)

Your message dated Wed, 01 Dec 2004 16:17:04 -0500
with message-id <E1CZbqS-0001g0-00@newraff.debian.org>
and subject line Bug#283754: fixed in ddetect 1.11
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 1 Dec 2004 02:20:58 +0000
>From joey@kitenet.net Tue Nov 30 18:20:58 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CZK70-0005ME-00; Tue, 30 Nov 2004 18:20:58 -0800
Received: from dragon.kitenet.net (unknown [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 04BE417DC6
	for <submit@bugs.debian.org>; Wed,  1 Dec 2004 02:20:58 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id D7CC36E26E; Tue, 30 Nov 2004 21:22:32 -0500 (EST)
Date: Tue, 30 Nov 2004 21:22:32 -0500
From: Joey Hess <joeyh@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: hppa install on a500
Message-ID: <20041201022232.GA26344@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="huq684BweRXVnRxX"
Content-Disposition: inline
X-Reportbug-Version: 3.2
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Package: installation-reports
Severity: normal

Debian-installer-version: today's hppa netboot daily build
Method: Netbooted, installed from my local sarge mirror.

Machine: hppa a500 (I think, it's not mine)
Processor: dual 550 mhz PA8600
Memory: 1994 mb
Root Device: /dev/sda5
Root Size/partition table:
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           4       32098+  f0  Linux/PA-RISC boot
/dev/sda2               5          20      128520   83  Linux
/dev/sda3              21        8924    71521380    5  Extended
/dev/sda5   *          21          54      273073+  83  Linux
/dev/sda6              55         662     4883728+  83  Linux
/dev/sda7             663        1027     2931831   83  Linux
/dev/sda8            1028        1789     6120733+  82  Linux swap
/dev/sda9            1790        1838      393561   83  Linux
/dev/sda10           1839        8924    56918263+  83  Linux

Output of (lspci ; lspci -n) |sort -n:

0000:00:00.0 0200: 1011:0019 (rev 41)
0000:00:00.0 Ethernet controller: Digital Equipment Corporation DECchip 211=
42/43 (rev 41)
0000:00:01.0 0100: 1000:000b (rev 07)
0000:00:01.0 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 =
(rev 07)
0000:00:01.1 0100: 1000:000b (rev 07)
0000:00:01.1 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 =
(rev 07)
0000:00:02.0 0100: 1000:000f (rev 14)
0000:00:02.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev=
0000:00:02.1 0100: 1000:000f (rev 14)
0000:00:02.1 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev=
0000:00:04.0 0700: 103c:1048 (rev 02)
0000:00:04.0 Serial controller: Hewlett-Packard Company Diva Serial [GSP] M=
ultiport UART (rev 02)
0000:00:05.0 0700: 103c:1048 (rev 02)
0000:00:05.0 Serial controller: Hewlett-Packard Company Diva Serial [GSP] M=
ultiport UART (rev 02)
0000:10:00.0 0200: 12ae:0001 (rev 01)
0000:10:00.0 Ethernet controller: Alteon Networks Inc. AceNIC Gigabit Ether=
net (rev 01)
0000:20:00.0 0200: 12ae:0001 (rev 01)
0000:20:00.0 Ethernet controller: Alteon Networks Inc. AceNIC Gigabit Ether=
net (rev 01)
0000:30:02.0 0100: 1000:0021 (rev 01)
0000:30:02.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1010 66M=
Hz  Ultra3 SCSI Adapter (rev 01)

Note that this system has 3 ethernet cards. The two Alteon's are in pci
slots, the other one is built in.

Base System Installation Checklist:
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


This was my first hppa install. Most of the install (the entire first
stage) was performed noninteractively using my preseeding and digress
framework. The first stage install went fine, although out of several
dozen I've done today in teaking digress to work with hppa, I did
experience one that hung the machine during partman disk formatting to
the point that linux stopped responding to pings. And of course partman
is slow on hppa with the 2.4 kernel.

Anyway, problems began in second stage boot. I'm using the network
console, and got some alerts. A truncated version of the first one,
which happended before linux booted at all:

************* SYSTEM ALERT **************
ALERT LEVEL: 6 =3D Boot possible, pending failure - action required
SOURCE: 8 =3D I/O=20

I accepted this alert, and it went on to boot linux. So what does this alert
mean, anyone know? Any way to disable it?

Then I got a second alert:

Detecting hardware: de4x5 acenic sym53c8xx_2
Roading de4x5 module.
SOURCE: 0 =3D unknown, no source stated
SOURCE DETAIL: 0 =3D unknown, no source stated   SOURCE ID: FF

Here it hung. Apparently de4x5 is not happy with this hardware. This was
kernel 2.4.27-64-smp BTW. I reset the machine and discover didn't load
de4x5 this time since it hung before, and the system came up to
base-config ok, and the network even worked.=20

eth0: Digital DS21143 Tulip rev 65 at 0x80, 00:30:6E:1C:90:2E, IRQ 128.
eth0: Setting half-duplex based on MII#1 link partner capability of 0021.

So the tulip driver is compiled in, is used, and presumaly gets pissed off
when de4x5 tries to take over the same card. :-/

The other two ethernet cards did not come up, since discover wants to load
the acenic module for them, and this module does not exist with the 2.4.27
hppa kernel.

I notice that de4x5 is not included in the d-i udebs at all, which is
probaly why my first stage install succeeded. Perhaps it should be dropped
=66rom the hppa kernel entirely, if all it does is conflict with tulip and
crash boots..

For some reason it wanted to configure console-data in the second stage.
Not sure why, though I've seen this on sparc and s390 too.

The rest of the install went ok.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)



Received: (at 283754-close) by bugs.debian.org; 1 Dec 2004 21:19:55 +0000
>From katie@ftp-master.debian.org Wed Dec 01 13:19:55 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CZbtD-0007cf-00; Wed, 01 Dec 2004 13:19:55 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CZbqS-0001g0-00; Wed, 01 Dec 2004 16:17:04 -0500
From: Joey Hess <joeyh@debian.org>
To: 283754-close@bugs.debian.org
X-Katie: $Revision: 1.54 $
Subject: Bug#283754: fixed in ddetect 1.11
Message-Id: <E1CZbqS-0001g0-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Wed, 01 Dec 2004 16:17:04 -0500
Delivered-To: 283754-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 2

Source: ddetect
Source-Version: 1.11

We believe that the bug you reported is fixed in the latest version of
ddetect, which is due to be installed in the Debian FTP archive:

  to pool/main/d/ddetect/archdetect_1.11_i386.udeb
  to pool/main/d/ddetect/ddetect_1.11.dsc
  to pool/main/d/ddetect/ddetect_1.11.tar.gz
  to pool/main/d/ddetect/ethdetect_1.11_all.udeb
  to pool/main/d/ddetect/hw-detect-full_1.11_all.udeb
  to pool/main/d/ddetect/hw-detect_1.11_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 283754@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated ddetect package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed,  1 Dec 2004 16:14:06 -0500
Source: ddetect
Binary: hw-detect-full archdetect hw-detect ethdetect
Architecture: source i386 all
Version: 1.11
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 archdetect - Hardware architecture detector (udeb)
 ethdetect  - Detect network hardware and load kernel drivers for it (udeb)
 hw-detect  - Detect hardware and load kernel drivers for it (udeb)
 hw-detect-full - Detect hardware and load kernel drivers for it (full version) (udeb)
Closes: 282814 283754
 ddetect (1.11) unstable; urgency=low
   * Colin Watson
     - Portable shell fix in hotplug-pcmcia.
   * Joey Hess
     - Work around de4x5 / tulip problem by using tulip if de4x5 is not
       available, and blacklisting de4x5. So we can control which is used
       on a per-arch or kernel basis by including the right one on the
     - If above hack causes tulip to be used for the first stage, call
       register-modules to make it be used on the installed system.
       Closes: #282814
     - On hppa 2.4 this doesn't happen, since tulip is built in.
       In that case, de4x5 will still be blacklisted so the hang will be
       avoided. Closes: #283754
   * Updated translations:
     - Catalan (ca.po) by Jordi Mallach
     - Czech (cs.po) by Miroslav Kure
     - Finnish (fi.po) by Tapio Lehtonen
     - Italian (it.po) by Giuseppe Sacco
     - Dutch (nl.po) by Bart Cornelis
     - Romanian (ro.po) by Eddy Petrisor
     - Russian (ru.po) by Russian L10N Team
     - Slovenian (sl.po) by Jure Ä?uhalev
     - Albanian (sq.po) by Elian Myftiu
     - Traditional Chinese (zh_TW.po) by Tetralet
 2980b5f88e524b5b1f8348152b279b11 844 debian-installer standard ddetect_1.11.dsc
 b4c6ae2e35d287411fd974251971308a 105117 debian-installer standard ddetect_1.11.tar.gz
 abd049646cba75c34c7d795479544e30 30600 debian-installer optional ethdetect_1.11_all.udeb
 f7aa847e188c63b78b7b4d3e16af2529 2676 debian-installer standard hw-detect-full_1.11_all.udeb
 6bf96ba88782e5cec39710e7cd5cafc6 50488 debian-installer standard hw-detect_1.11_i386.udeb
 42ba9e0e76c8d4db646710aa8641338b 2352 debian-installer standard archdetect_1.11_i386.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)


Reply to: