[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

questions for kernel-team (fwd)

I sent this to the bug where I found the issue mentioned, but that
didn't replicate the message to debian-boot. I'm sending here because
it's an issue more related to the installer.

---------- Forwarded message ----------
To: 227705@bugs.debian.org


this issue (ide=nodma boot time option does not work) is blocking a
possible workaround for a number of other bug reports (all to do with
DMA errors mucking up the cdrom-detect and/or cdrom-retriever steps of
the installation from netinst). Example bugs: 265636, 258316, 250323,
maybe 283016.

This issue is still present in i386 RC2 netinst, I tried booting with
  linux ide=nodma
  expert ide=nodma
  linux26 ide=nodma
and in all cases the installer failed as in 265636, with dma errors
when trying to access the package pool.
I also tried giving the "nodma" option to the ide-cd module in
when loading it in the "expert" mode. This too was ignored.

Could someone on the team briefly explain why ide=nodma is disabled?

Is it that turning off dma does not work reliably?

If yes, then what do you think the negative effects would be of setting
Before resigning from Debian, Herbert Xu was considering turning this
on (#250323).

Also, it appears that
and if so is that a good idea when trying to support older h/w?

This close to release, I would not normally bring up changing the kernel
config, except that these bugs seem to occur on older Dell hardware
fairly often. So there may be a fairly large potential user base affected.

Kind regards

Reply to: