[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283712: Installation Report (Reboot from USB Hard Disk failed)

Package: installation-reports

Debian-installer-version: 24/11/2004 - http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/rc2/sarge-i386-netinst.iso uname -a: Linux t3 2.6.8-1-386 #1 Thu Nov 11 12:18:43 EST 2004 i686 GNU/Linux (hmm, must reset the clock!)
Date: 26/11/2004
Method: Downloaded netinst iso, burned to CDROM, installed from External USB 2 CDRW drive (Pika One Ripcase 8000) onto External USB 2 Hard Disk (Lacie/Maxtor 7Y250P0 250G).

Machine: Tranquil T3 (EPIA PD6000E Mini-ITX motherboard, no internal IDE disks)
Processor: VIA Eden 600Mhz
Memory: 512MB
Root Device: USB 2 hard disk (Lacie/Maxtor 7Y250P0 250G) /dev/sda1
Root Size/partition table:
Disk /dev/sda: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       30334   243657823+  83  Linux
/dev/sda2           30335       30515     1453882+   f  W95 Ext'd (LBA)
/dev/sda5           30335       30515     1453851   82  Linux swap

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8623 [Apollo CLE266]
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
0000:00:0f.0 Ethernet controller: VIA Technologies, Inc. VT6105 [Rhine-III] (rev 8b) 0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80) 0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80) 0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) 0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50) 0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74) 0000:01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo CLE266] integrated CastleRock graphics (rev 03)
0000:00:00.0 0600: 1106:3123
0000:00:01.0 0604: 1106:b091
0000:00:0f.0 0200: 1106:3106 (rev 8b)
0000:00:10.0 0c03: 1106:3038 (rev 80)
0000:00:10.1 0c03: 1106:3038 (rev 80)
0000:00:10.2 0c03: 1106:3038 (rev 80)
0000:00:10.3 0c03: 1106:3104 (rev 82)
0000:00:11.0 0601: 1106:3177
0000:00:11.1 0101: 1106:0571 (rev 06)
0000:00:11.5 0401: 1106:3059 (rev 50)
0000:00:12.0 0200: 1106:3065 (rev 74)
0000:01:00.0 0300: 1106:3122 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [E]


Initial boot from External USB 2 CDROM was flaky and time dependent. Closing the drive door at the time the machine booted seemed to get it to boot most times. Not sure if hardware or software problem.

Using 2.4 kernel to install with, installation was great up to reboot time. Using 2.6 kernel to install with, it failed to read the CDROM part way through the "Install base system" step (made lots of nasty grunching noises as well).

So, I tried installing both 2.4 and 2.6 target kernels using 2.4 CDROM kernel. Reboot failed under both 2.4 and 2.6 target kernels with:

pivot_root: file not found.
kernel panic: attempted to kill init!

That scared me a bit - very obscure! However, turned out it was easy to fix once I figured out what the problem was. It would have easier for me to figure out if the pivot_root error was more helpful.

Turned out that pivot_root was failing because the target kernel hadn't detected the USB hard drive - the required USB modules were missing (even though the CDROM kernel seemed to have them). To fix this I mostly followed the instructions in:


Basically this meant running the install in expert mode, starting a shell before rebooot, and then:

- nano /target/etc/mkinitrd/modules to add the USB modules (I used sd_mod, ehci-hcd, uhci-hcd, ohci-hcd, usb-storage for 2.6 kernel) - nano /target/etc/mkinitrd/mkinitrd.conf to add DELAY=10 (this wasn't in the original email but was required for the USB to have time to detect the drive)
- chroot /target
- mkinintrd -o /boot/initrd-<version> [<version> if installing 2.6 from 2.4]
- (mkinitrd helpfully prompts you to mount proc, follow the instructions and try again ;-)

Finally exit the shell and finish the installation normally.

In the end I booted off CDROM using "expert" (2.4) to avoid the CDROM read problem and installed 2.6. I did try 2.4 -> 2.4 and booted OK but seemed to loose the network - but I only tried that once. Using 2.4 -> 2.6, the second phase worked first time.

The box is now ready to go in the cupboard and serve flac's to my squeezebox ;-).

It would be really great if we could add those few USB modules to the target initrd for those ppl out there booting off USB (especially non experts like me)!

Reply to: