[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283429: d-i rc2 on ppc: 2.4 kernel bombs out, 2.6 okay. Some problems remain



Package: installation-reports

INSTALL REPORT

First the "template blurb". :-)

Debian-installer-version: RC2 Netinst for PPC
uname -a: Linux anna 2.6.8-powerpc-fbfix #1 Sun Sep 5 16:44:53 CEST 2004 ppc GNU/Linux
Date: 2004-11-27 00:00 CET 
Method: CD image

Machine: iBook 2.2 (800 MHz Combo)
Processor: 750FX
Memory: 640 MB
Root Device: TOSHIBA MK3018GAS, ATA DISK drive
Root Size/partition table:  

/dev/hda
        #                    type name                 length   base     ( size )  system
/dev/hda1     Apple_partition_map Apple                    63 @ 1        ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap boot                   1661 @ 64       (830.5k)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 root                 480835 @ 1725     (234.8M)  Linux native
/dev/hda4               Apple_HFS Apple_HFS_Untitled_7 16922816 @ 482560   (  8.1G)  HFS
/dev/hda5         Apple_UNIX_SVR2 swap                 976563 @ 17405376 (476.8M)  Linux swap
/dev/hda6         Apple_UNIX_SVR2 tmp                 1562501 @ 18381939 (762.9M)  Linux native
/dev/hda7               Apple_HFS Apple_HFS_Untitled_9 22430704 @ 36174400 ( 10.7G)  HFS
/dev/hda8         Apple_UNIX_SVR2 var                 1953126 @ 19944440 (953.7M)  Linux native
/dev/hda9         Apple_UNIX_SVR2 home                4882813 @ 21897566 (  2.3G)  Linux native
/dev/hda10        Apple_UNIX_SVR2 usr                 5859376 @ 30315024 (  2.8G)  Linux native
/dev/hda11             Apple_Free Extra               3534645 @ 26780379 (  1.7G)  Free space
/dev/hda12             Apple_Free Extra                    16 @ 58605104 (  8.0k)  Free space

Block size=512, Number of Blocks=58605120
DeviceType=0x0, DeviceId=0x0

Output of lspci and lspci -n:

0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea AGP
	Flags: bus master, 66MHz, medium devsel, latency 16
	Capabilities: <available only to root>

0000:00:10.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
	Flags: bus master, stepping, 66MHz, medium devsel, latency 255, IRQ 48
	Memory at 98000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 802400 [size=256]
	Memory at 90000000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at f1000000 [disabled] [size=128K]
	Capabilities: <available only to root>

0001:01:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea PCI
	Flags: bus master, 66MHz, medium devsel, latency 16

0001:01:17.0 ff00: Apple Computer Inc. KeyLargo/Pangea Mac I/O
	Flags: bus master, medium devsel, latency 16
	Memory at 80000000 (32-bit, non-prefetchable) [size=512K]

0001:01:18.0 USB Controller: Apple Computer Inc. KeyLargo/Pangea USB (prog-if 10 [OHCI])
	Flags: bus master, medium devsel, latency 16, IRQ 27
	Memory at 80081000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <available only to root>

0001:01:19.0 USB Controller: Apple Computer Inc. KeyLargo/Pangea USB (prog-if 10 [OHCI])
	Flags: bus master, medium devsel, latency 16, IRQ 28
	Memory at 80080000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <available only to root>

0002:02:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea Internal PCI
	Flags: bus master, 66MHz, medium devsel, latency 16

0002:02:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth/Pangea FireWire (prog-if 10 [OHCI])
	Subsystem: Apple Computer Inc. UniNorth/Pangea FireWire
	Flags: bus master, 66MHz, medium devsel, latency 16, IRQ 40
	Memory at f5000000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <available only to root>

0002:02:0f.0 Ethernet controller: Apple Computer Inc. UniNorth/Pangea GMAC (Sun GEM)
	Flags: bus master, 66MHz, slow devsel, latency 16, IRQ 41
	Memory at f5200000 (32-bit, non-prefetchable) [size=2M]
	Expansion ROM at f5100000 [disabled] [size=1M]

lspci -n:

0000:00:0b.0 0600: 106b:0027
0000:00:10.0 0300: 1002:4c57
0001:01:0b.0 0600: 106b:0028
0001:01:17.0 ff00: 106b:0025
0001:01:18.0 0c03: 106b:0026
0001:01:19.0 0c03: 106b:0026
0002:02:0b.0 0600: 106b:0029
0002:02:0e.0 0c00: 106b:0030
0002:02:0f.0 0200: 106b:0024

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O/E] 	# 2.6.8 image OK, 2.4.27 failed
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]

Comments/Problems:

Note bug #266472 is an installation report with RC1 Netinst on the same
machine.


First stage.
============

Booting kernel 2.4.27 fails with an error message 

	attempt to access beyond end of device
	01:00: rw=0 want=8202 limit=8192

filling up the screen quickly, right after the "RAMDISK ... erm...
found?  rejected?--to quick to read" message. 
Guess: bogus initrd? (But I can mount
/media/cdrom/install/powerpc/2.4/initrd.gz manually with no problems.)

The default kernel 2.6.8 is fine when booted with "video=ofonly". The
default commandline gives a black screen -- this is kernel bug #270743
("radeonfb cannot detect panel size and breaks").  AFAIK this requires a
kernel patch to run X, since X depends on radeonfb.  For this reason I
do no longer run the d-i kernel.

bogl-bterm bug #273192 (?) swapped red and blue colours in d-i (first
stage only).  I'd like to note that

- this does not go away when I switch to another terminal
- it happened with d-i rc1 and _both its kernels 2.6 and 2.4_ also.

Apart from that, the installation was pretty smooth (non-expert install).
Hm, did any other thing go wrong here? Some kernel modules -- usbkbd,
hid, ide-generic --  were not found, and therm_windtunnel doesn't find a
matching device (nevertheless it is listed in /etc/modules). I do not
know these modules, but it does not seem to be critical. Though this
could be improved.
Ah, I almost forgot, why doesn't d-i check the network link with
mii-tools? When there's no ethernet cable plugged in, it doesn't
complain, but tries DHCP...
And a very minor thing: it would be nicer if the placeholder in d-i's
main menu would really be a separator, and not an unnamed dummy action
that "fails" upon selection :-)


Second stage.
=============

The basic system setup was fine. 

There were problems with xfree and xterm that I think are worth
elaborating, since these are rather basic packages, and for some reason
I always get an Exim zombie child (Exim is debconf'ed), but I haven't
yet investigated this.  
Further, some (likely) kernel bugs remain unresolved, but they are quite
hard to track down. I'll give some notes on these later.

Configuring XFree86.
--------------------

The semi-autogenerated configuration of xserver-xfree86 needed some
corrections. 

Note that at this point, the default d-i kernel was still in business,
using the Open Firmware framebuffer driver. I reinstalled xfree later
with my patched kernel to see if it does a better job with a functional
radeonfb driver, but gave up testing as I figured from
xserver-xfree86.config that this doesn't seem to compare to a clean,
fresh install. 
These fixes were necessary:

* The graphics driver had to be given the option "UseFBDev". Without
  there's just a blank screen.
  AFAICS, at least this was caused by the broken/not-running radeonfb.

* Keyboard setup was broken:

,----[ XF86Config-4, keyboard section ]
| Section "InputDevice"
| 	Identifier	"Generic Keyboard"
| 	Driver		"keyboard"
| 	Option		"CoreKeyboard"
| 	Option		"XkbRules"	"xfree86"
| 	Option		"XkbModel"	"pc105"
| 	Option		"XkbLayout"	"de"
| 	Option		"XkbOptions"	"nodeadkeys"
| EndSection
`----

  AFAIK "nodeadkeys" isn't an XKB Option but a Variant. In the form
  above, it had no effect. 

("pc105" also looks wrong, I think it should be "macintosh", but no
problems yet.)

* I didn't manage to find the mode_switch (AltGr) on the keyboard, but
  the XKB option "grp:win_switch" fixed that. This hack dates to my
  previous install with d-i rc1, I don't remember the details now, but I
  was quite involved with XKB :-).

* The monitor modelines were missing entries for 1024x768, only 800x600
  and 640x480 were listed. This garbled the screen. 

* Choosing auto-detection for the mouse put two mouse sections;
  surprisingly, this works anyhow:

,----[ mouse section ]
| Section "InputDevice"
| 	Identifier	"Configured Mouse"
| 	Driver		"mouse"
| 	Option		"CorePointer"
| 	Option		"Device"		"/dev/psaux"
| 	Option		"Protocol"		"ImPS/2"
| 	Option		"Emulate3Buttons"	"true"
| 	Option		"ZAxisMapping"		"4 5"
| EndSection
| Section "InputDevice"
| 	Identifier	"Generic Mouse"
| 	Driver		"mouse"
| 	Option		"SendCoreEvents"	"true"
| 	Option		"Device"		"/dev/input/mice"
| 	Option		"Protocol"		"ImPS/2"
| 	Option		"Emulate3Buttons"	"true"
| 	Option		"ZAxisMapping"		"4 5"
| EndSection
`----

Get xterm to work.
------------------

See Bug #279252. uxterm is the default alternative for
x-terminal-emulator. A fresh system has no UTF locale installed, this
breaks x-terminal-emulator. 

Remaining kernel issues.
------------------------

There are still at least two nasty kernel problems. Both seem to occur
randomly, I cannot tell when or why. :-(
First, having a XFS root filesystem, during shutdown
/etc/init.d/umountfs hangs at the last lines:

,----[ umountfs ]
| #	Umount all filesystems except the virtual ones.
| #
| echo -n "Unmounting local filesystems..."
| umount -tnoproc,noprocfs,nodevfs,nosysfs,nousbfs,nousbdevfs,nodevpts -d -a -r
| echo "done."
|
| # This is superfluous.
| mount -n -o remount,ro /
|
| : exit 0
`----

The final remount hangs. The syscall, more precisely. This is
surprising, since the root fs _is_ already remounted read-only. I tried
to track it down by sprinkling printf() calls in the kernel code, but
I'm not done identifying the crucial, failing routine.  XFS seems to
hang when it tries to flush the filesystem. Weird.
This problem occurred with my previous install from d-i rc1. 
For the moment, I sidestepped it for my new install by avoiding an XFS
root. Perhaps I'll debug this further when I have some time.

Second, from time to time, the keyboard goes mad while I type. No idea
what's going on :-/ 
Symptoms are different running X or at the console:

* With X, it's like when the mode_switch is toggled. This means I get
  special symbols as default, pressing the mode_switch key makes the
  keyboard normal again. In addition, pbbuttonsd ejects the CD on _any
  key_, even when I press shift... Wow.

* At the console, normal typing is possible, but password
  authentications like for login and sudo always fail and make the
  screen fill up with "^@" symbols (which is the null character, I am
  told) until e.g. the login timeout (60 seconds) has passed. Then I get
  the login prompt again. Very interesting. :-)

Any hints are appreciated.

Hm, after so much criticism... keep up the good work, guys. I think my
iBook is a tough nut to crack. :-) 


All the best,
Nikolaus




Reply to: