[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283318: Installation results in an unbootable system

Package: installation-reports

Debian-installer-version: sarge-i386-1.iso, 15.11.2004, ftp.acc.umu.se
uname -a: Linux t1 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i686 unknown
Date: 20.11.2004
Method: Debian boot-CD, IDE drive

Machine: NoName-PC (board MS6119)
Processor: PII-233 MMX
Memory: 128 MB
Root Device: IDE (Seagate ST 34342A)
Root Size/partition table: 1: 4.1 GB root, 5: 200 MB swap, boot loader in MBR

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 02)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 01)

0000:00:00.0 0600: 8086:7190 (rev 02)
0000:00:01.0 0604: 8086:7191 (rev 02)
0000:00:07.0 0601: 8086:7110 (rev 02)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 02)
0000:00:0e.0 0200: 10ec:8139 (rev 10)
0000:01:00.0 0300: 102b:0521 (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]	(manually)
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


GRUB loading stage 1.5.
GRUB loading, please wait...
Error 18

That's all what I get after reboot.

I'm not familiar with grub, but error 18 indicates a problem with the
disk geometry. And indeed after the reboot the BIOS recognizes a wrong
disk geometry (495 MB instead of the original 4.3 GB).
I have retried the installation, even with another board
(MS6140 / Celeron 300A), but I always get the same result.
I had to overwrite the disk (with dd) to get the original disk geometry
back (displayed in the BIOS).

Today I have checked installation from the updated sarge-i386-1.iso
image from 22.11.2004, same result. Installing woody and upgrading it
to sarge works fine on the same system now.

As this is my first try with the new installer a few additional

- It would be nice to have a rescue boot mode as with the woody disks.

- The network config happily ignores a missing dhcp server:
  "The network autoconfiguration was successful." ... but nothing was
  It should switch to manual configuration mode instead or at least give
  an adequate error message.

- The meaning of the symbols in the disk partition screen should be
  explained (smiley, skull, bolt, ..) or better be replaced by self
  explaining text.

- There are often empty "blue screens" for a more or less lasting time
  during the installation (e.g. between partitioning and installing
  the base system).
  This may not be a problem on a fast machine. But on a slower machine
  this may give the impression of a crashed installation, especially
  for windows users.
  If the system has to do something there should be a message or a
  progress bar on the screen, but not an empty screen.



Reply to: