[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283170: installation-reports: Success on OldWorld Power Mac 6500/250

Package: installation-reports

Debian-installer-version: 26-Nov-2004; floppy images from <URL: http://people.debian.org/~luther/debian-installer/daily-powerpc-built/2004-11-26/powerpc/floppy-2.4/>

uname -a: Linux quack 2.6.8-powerpc #1 Sun Oct 3 13:22:21 CEST 2004 ppc GNU/Linux

Date: 26-Nov-2004, 2200 UTC

Method: Installed from three floppies (boot, root, net-drivers), the
        machine has a ne2k-pci network card.  Direct HTTP connection to
        the Internet.

Machine: Apple Power Mac 6500/250
Processor: 603ev, 250MHz
Memory: 32MB
Root Device: IDE; /dev/hda2
Root Size/partition table: 4 partitions, hda1 is the Apple partition
                           table, hda2 is / (1 GB), hda3 is swap space
                           (256MB), hda4 is /home (1.8GB).

Output of lspci and lspci -n:
0000:00:0b.0 Host bridge: Apple Computer Inc. Bandit PowerPC host bridge (rev 03)
0000:00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
0000:00:10.0 ff00: Apple Computer Inc. O'Hare I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT

0000:00:0b.0 0600: 106b:0001 (rev 03)
0000:00:0e.0 0200: 10ec:8029
0000:00:10.0 ff00: 106b:0007 (rev 01)
0000:00:12.0 0300: 1002:4754 (rev 41)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]


I booted from the boot floppy, then inserted the root floppy, I was then
presented with a message telling me that the installer had started in
low-memory mode (the machine has 32MB of physical memory).  The "select
language" items were still present in the d-i menu but ineffective since
I was in low memory mode.

I then proceeded to install drivers from the net-drivers floppy but d-i
hadn't ejected the root floppy and floppy drives on Macs don't have an
eject button.  I had to eject the disk forcibly using a pin and the
"rescue eject" function.  The woody installer used to eject the root
floppy as soon as it had finished loading the system, I think that would
be nice in d-i too.

My network card, a ne2k-pci card, was detected and DHCP worked fine.  I
selected as few installer modules as possible, everything worked okay.
The hardware detection was somewhat faulty, it wanted to load drivers
for a dozen of IDE chipsets.  I unselected them all from the list of
drivers to load and loaded the floppy and ide-disk modules only, the
hard drive was detected fine.  Partitioning was _very_ slow: there was a
~10 second delay between each screen, even more when it needed to
perform operations on disk.  I didn't see any obvious reason for the
slowdown in the logs or in a shell.

The rest of the installation was fine until the very end.  I tried to
select a 2.6.8 kernel from the list of available kernels but
installation failed, in the log console I saw that it aborted because
preinst (or postinst, I don't know) was asking for confirmation about
the initrd.  Retrying with 2.4.27 worked fine, apparently because d-i
set do_initrd in kernel-img.conf for this image and not for the 2.6 one

The most difficult part of the install was installing a bootloader.
Installing Quik from the d-i menu failed every time, so I googled a bit
for the solution.  I will repeat the exact steps I followed since it
might be useful to someone else with a Power Mac 6500:

1. Create /dev/nvram with mknod /dev/nvram c 10 144

2. Use /target/sbin/nvsetenv to change OpenFirmware values like this:

# /target/sbin/nvsetenv boot-device ata/ata-disk@0:2
            2 if the root device is /dev/hda2, 3 for hda3, etc

# /target/sbin/nvsetenv input-device kbd
# /target/sbin/nvsetenv output-device /bandit/ATY,264GT-B

3. Check that /target/etc/quik.conf exists and looks okay (with nano)

4. Install quik from the shell:

# /target/sbin/quik -v -r /target

Then proceed with the installation.  Using "install a bootloader" at
least once is important, quik.conf doesn't get created otherwise.

I finished the installation and rebooted without problems.  The end of
the configuration detected a CD in my drive and automatically used it to
setup sources.list, replacing my http entries.  The CD was an old woody
ppc CD, it would have been nice for the installer to detect this and not
try to use it to install packages.  I fixed sources.list myself in
another terminal before proceeding with the actual install.

After the installation I upgraded Quik with the a new version (see <URL:
http://lists.debian.org/debian-devel/2004/11/msg00856.html> and
installed the 2.6.8 kernel image from sarge for powerpc, which installed
and booted fine with an initrd.

All in all, I'd say d-i was very impressive for this installation.  Much
easier to use than b-f, and much more powerful.  Thanks for the
excellent work on the installer!


 : :' :        Romain Francoise <rfrancoise@debian.org>
 `. `'         http://people.debian.org/~rfrancoise/

Reply to: