[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#282547: Installation hangs/keyboard missing on IBM TP R40e

Package: installation-reports

Debian-installer-version: 20041120 sarge
uname -a: didn't boot, but 2.6.8-1-686
Date: 2004.11.22.1300
Method: netinst

Machine: IBM ThinkPad R40e
Processor: Mobile Intel(R) Celeron(R) CPU 2.40GHz
Memory: 370468
Root Device: IDE
Root Size/partition table: 
/dev/hda1               1        2067      976626   82  Linux swap
/dev/hda2            2068       28935    12695130   83  Linux
/dev/hda3           28936       55358    12484867+  83  Linux

/dev/hda2 is a 2.6.6 debian install
/dev/hda3 is a suse 9.2

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (rev 02)
0000:00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
0000:00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:03.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem]
0000:00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
0000:00:06.0 Bridge: ALi Corporation M7101 PMU
0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
0000:00:0b.0 Ethernet controller: Broadcom Corporation: Unknown device 170d (rev 01)
0000:00:0c.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
0000:00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 340M
0000:02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.: Unknown device 8180 (rev 20)

0000:00:00.0 Class 0600: 1002:cab2 (rev 02)
0000:00:01.0 Class 0604: 1002:7010
0000:00:02.0 Class 0c03: 10b9:5237 (rev 03)
0000:00:03.0 Class 0703: 10b9:5457
0000:00:04.0 Class 0401: 10b9:5451 (rev 02)
0000:00:06.0 Class 0680: 10b9:7101
0000:00:07.0 Class 0601: 10b9:1533
0000:00:0b.0 Class 0200: 14e4:170d (rev 01)
0000:00:0c.0 Class 0607: 104c:ac56
0000:00:0f.0 Class 0101: 10b9:5229 (rev c4)
0000:01:05.0 Class 0300: 1002:4337
0000:02:00.0 Class 0200: 10ec:8180 (rev 20)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]


The machine hangs itself up when starting sysklogd when starting
linux26. When starting expert26, it just freezes after the screen is
cleared the first time, leaving the cursor blinking at the lower
left corner. This is reproducible.

I tried BOOT_DEBUG=255, but I cannot read the output as it scrolls
too fast, I do not have a serial console available, and flow control
is apparently not (yet) operable.

The boot works fine if I specify either of

  expert26 debian-installer/probe/usb=false
  linux26 debian-installer/probe/usb=false

at the boot prompt (added to the Wiki).

The R40e also suffers from the "missing keyboard" bug (see Wiki),
for which only the Caps Lock workaround seems to work -- very

"A good case, a mediocra computer..."

Please do not CC me when replying to lists; I read them!
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!

Attachment: signature.asc
Description: Digital signature

Reply to: