[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#281295: [i386] [20041113] [netinst] LILO installation failed (RAID+LVM)

Package: installation-reports

Debian-installer-version: 2004-11-13 sarge-i386-netinst.iso
uname -a: n/a
Date: 2004-11-14
Method: linux26, booted from ISO as virtual CD-ROM

Machine: VMware Workstaton 4.5.2 build-8848,
         Microsoft Windows XP Professional 5.1.2600, Service Pack 2
Processor: Intel Pentium III, 500 MHz
Memory: 128 MB for virtual machine,
        448 MB on physical machine
Root Device: lv0 on md1 (RAID-1 sda2+sdb2)
Root Size/partition table: md0 (sda1+sdb1) as swap (128 MB),
                           rest as root (ca 4 GB)
Output of lspci and lspci -n: n/a

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]


You could simplify RAID component device selection screen as user might not be familiar with host/bus/target/lun/part naming scheme. Base partitioning screen is a good simple example.

During the base system install my machine crashed, so some RAID and LVM settings were lost and i had to go again through it. After entered LVM configuration it was possible to activate existing volume group as i didn't touch existing partition sizes.

There could be possibility to see current LVM groups and volumes setup during LVM configuration. It were possible to have overview, what has been done, after leaving LVM configuration.

I did not format root partition either, so base system install gave me a warning about that and as i decided to go back, installation system said, that base system installation step failed. But did it failed, really? I think it did not. So there must be a different notice or no notice at all - did it failed really or decided user to go back and should automatically taken to, where we were previously.

Had gone back and ordered installation to format swap and root again. Noticed, that overview did know, what use partitions had but detailed view did not - had to say again that md1 should be ext3 mounted as root and md0 swap.

LILO installation. md1, MBR - i allowed to make partition active - failed. md1, new Debian partition - again asked to make partition active which i allowed - installation failed. md1, MBR - this time skipped partition activation - installation failed - /sbin/lilo error code 1. md1, new Debian partition - did without partition activation - again /sbin/lilo error 1. Tried advanced - "/dev/md/1 does not represent a partition or hard disk device", but checked that /dev/md/1 does exist. Tried /dev/md1 - again no success. Also no luck with /dev/mapper/vg0-lv0...

After little thinking it came up to my memory, that i've seen a Debian box with raid+lvm before and i managed to get this machine's fstab file. So, what i see... There's a /boot partition which is plain raid1, not lvm! Ok then, bye-bye to already installed base system...

(To be continued in separate report...)

Joosep-Georg Järvemaa

"Trying to determine what's real and what's not is like making a Venn diagram."
  -- jesus_x@mozillanews.org in article "Google's Browser Plans"

Reply to: