[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Search for patched yaboot testers ...

On Nov 10, 2004, at 6:01 AM, Sven Luther wrote:

On Wed, Nov 10, 2004 at 03:46:58AM -0500, Rick Thomas wrote:
The new yaboot seems to work at least on one of my machines.  I'll
try some others later.

Specifically, I tried it on my Blue&White G3.  I booted holding
down the "C" key (ADB keyboard) and got the yaboot messages.  At
the "boot:" prompt, I typed "expert video=ofonly" and it did the
expected things.  In fact everything proceeded as expected til I

Ok, thanks, can you forward info about this to the bug report ? It is :


got to the partitioner, which hung up trying to look at the
partitions on the disk on my SIIG Ultra ATA 133/100 Pro IDE
controller PCI card.  The "dmesg" command on the "F2" console
showed a bunch of messages

	hdg: dma_timeout_expiry: dma status == 0x24
	AEC62XX timeout <4>hdg: lost interrupt

I've seen this before with 2.6 kernels.  I've reported it to the
list in installation reports, but nobody seems to care.

Can you fill a bug report about this against the powerpc
kernel-image-2.6.8-powerpc ? It seems to be a powerpc kernel problem.

So I was unable to proceed any further on that machine.

... later ...

I also tried it on my grey G4 minitower 733MHz.  Worked fine up to
partitioning disks.  This is a production machine with no free disk
partitions, so I couldn't proceed any further than that.  I've got
a G4 450MHz at work with some free partitions, so I'll try a full
install there tomorrow.

You tried only CD booting method, not net or disk, right ?

What was the bug number of the bug report you wanted me to reply to
for the new yaboot?

See above.

I got a chance to do an install from your mini.iso on a test machine. It's a "G4 350 MHz (AGP graphics)". I'm not clear as to whether this will install your test yaboot or not, but here's what happened:

I booted off the CD and chose the default (i.e. non-expert) install at the "boot:" prompt. I answered all the i18n questions with the default (US-English) and configured the network manually (no DHCP on this net). I chose the "debain.rutgers.edu" mirror because it's located in the next building over on the same campus and I have a 100-Mbit connection via campus LAN to it from the test machine. (I'm used to doing installs over a fairly fast cable-modem that gets about 4 Mbit/sec on a good day. This was *much* faster. <-8) When it came time to partition the disk, I chose a guided partitioning, and it set me up with a 1 MB "boot" partition, a 4 GB "root" partition, and a 260 MB swap partition.

Then, for some reason I don't understand, it tried to install the "quik" bootloader. This is definitely a NewWorld machine, so it should have known better -- I would think! In any case, that got an error, and it offered to let me install yaboot instead, which I did.

When the first phase was over, and it came time for the reboot, everything went completely as expected, and I finished the installation after an uneventful reboot. If this was using your new yaboot, then I'd say the test was successful.

If this sequence does *not* exercise your new yaboot, please give me instructions for what to do next. I'll be in Atlanta for the USENIX/LISA conference all next week, so my next opportunity for testing will be a week from now.



Reply to: